Hardcore Sledder banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
12,019 Posts
Looks like oil is coming out the weep hole in the waterpump. Anyone else?[/b]

Time to rebuild, probably a mixture of old bearing grease, h20, some 2 stroke oil.
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #3 ·
yeah, i figured it is time. I bought the sled with 2300 miles and did the pump right away, i just turned 8,000 miles last night. I believe what i noticed was black oil looking liquid thats on the square aluminum things the connects the tie rods for the steering. Right beneath the water pump. I also remember seeing the same (oil) stain on the pump coming from the weephole when i swapped the motor a few weeks ago.
 

·
Registered
Joined
·
9 Posts
yeah, i figured it is time. I bought the sled with 2300 miles and did the pump right away, i just turned 8,000 miles last night. I believe what i noticed was black oil looking liquid thats on the square aluminum things the connects the tie rods for the steering. Right beneath the water pump. I also remember seeing the same (oil) stain on the pump coming from the weephole when i swapped the motor a few weeks ago.[/b]
01xcr800 hi, my name is mark . sorry to steal your post, but you said you swapped your motor a couple weeks ago was wondering if you have a crankcase avalaible 99 to 03 xcr 800 would appreciate a call 218-779-2428 or e-mail thankyou very much!!!
 

·
Registered
Joined
·
668 Posts
Discussion Starter · #5 ·
01xcr800 hi, my name is mark . sorry to steal your post, but you said you swapped your motor a couple weeks ago was wondering if you have a crankcase avalaible 99 to 03 xcr 800 would appreciate a call 218-779-2428 or e-mail thankyou very much!!![/b]
Hi Mark, the motor i took out is in a friend's sled right now. I let him borrow it while his is at Flannery's.
 
1 - 5 of 5 Posts
Top