Hardcore Sledder banner
1 - 12 of 12 Posts

·
Registered
Joined
·
3,692 Posts
Discussion Starter · #1 ·
My xcr carbs have the green slides everyone says to replace 2 of them look good other than some of the coating being rubed off the other one has some dents in it where it contacts the body I will definatly replace the bad one but it would cf and go through the motorost $175 to replace all three. are they safe if they look good or can a peice snap off and go through the motor on any of them also Whal bros had them for $56 each is there anywhere I would get a better deal?
 

·
Registered
Joined
·
191 Posts
the only warning that we got that they were broken was high idle 4-5000rpm. my buddy didnt even here the engine stutter or anything. i would change them because you maybe looking at a broken, piston or a jug for that matter. the $175 is cheapeer than a new jug and piston
 

·
Registered
Joined
·
406 Posts
I had that happened to me twice on the '99 XCR800 and both times, the broken piece was caught in the VF cage. So lucky that it didnt get sucked inside the motor. WL.
 

·
Registered
Joined
·
396 Posts
My 99 started doing the high idle thing and by the time I got it back to camp and pulled it apart my first find was a piece of slide in the airbox and found the other piece (i had two corners broke off the same slide) was in the reed cage. I have heard of less fortunate results. I really liked that sled. Too bad they didn't have that engine in an edge switchback with electronic reverse!
 

·
Registered
Joined
·
3,692 Posts
Discussion Starter · #7 ·
My 99 started doing the high idle thing and by the time I got it back to camp and pulled it apart my first find was a piece of slide in the airbox and found the other piece (i had two corners broke off the same slide) was in the reed cage. I have heard of less fortunate results. I really liked that sled. Too bad they didn't have that engine in an edge switchback with electronic reverse![/b]
you can always build one I havent seen a xcr/switchback yet
 

·
Registered
Joined
·
904 Posts
today my brothers(00 xcr 800) started to almost sounded like it was backfireing all the time when you give it a little gas and not idle very good. did not sound good at all. he has pulled a piece (carb slide) out of the reeds before. could this be the problem again? any help would be great. ryan
 

·
Registered
Joined
·
15 Posts
The sled that rsracin is talking about is mine. I replaced a carb slide last year and the reed and and other slides looked fine. Do you think that I could have lost another slide? I runs fine wide open just at low rpm's. I'm not running it right now.
 
1 - 12 of 12 Posts
Top