Hardcore Sledder banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I picked up my sled on Friday and noticed oil in the pan while at the dealership. The dealer cleaned up the oil and said they most likely spilled oil while filling the tank. Today I ran the sled in the driveway and to get the motor up to temp. Shortly afterwards I noticed oil on the garage floor and the top of the oil cap was leaking a good amount of oil from the top of the cap down the side of the oil tank. this seems excessive as I have never had that much oil leak through the cap before.

Now I'm wondering if it's a bad oil cap or if I have a bad hose or leak somewhere else as well.

Also, I'm used to Polaris VES oil which is gold in color but the oil in the tank is red and seems pretty thin almost like water consistency. Is this normal and possibly a new version of Polaris VES oil?

Any thoughts on this?
 

·
Registered
19 600 Switchback Assault
Joined
·
306 Posts
The oil is probably VES extreme oil it's red a thinner than regular VES.
And for the leak, maybe they just overfill it.
And they filled it somewhere cold to the top and you put the sled in a heated garage the oil would expend amd spill maybe?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The oil is leaking up through the top vent of the cap and not from the threads as in some older oil cap issues. it does look like pressure in the tank or maybe just a bad cap.
 

·
Premium Member
MY21 650 SBA 146, ES, ICE Storm 1.5
Joined
·
6,120 Posts
The oil is probably VES extreme oil it's red a thinner than regular VES.
And for the leak, maybe they just overfill it.
And they filled it somewhere cold to the top and you put the sled in a heated garage the oil would expand and spill maybe?
We have a winner, get that man a Kewpie doll OR a funnel cake.

remember the O.P.... "ran the sled in the driveway to get the motor up to temp.+
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
It's still strange that much oil would leak through the top vent of the oil cap when running the sled for maybe 5 min in the driveway. Did this many times with my AXYS and never had this happen before?? The temp outside was around 40F and the garage was maybe 65F, not a big change in temp. The only other difference is I always use VES Full synthetic (orange label) and not VES Extreme which is a much thinner oil.
 

·
Registered
Joined
·
16 Posts
I also noticed leaking from the vent in my cap. Mines an 850. This was sitting out in front of the cabin. Nowhere heated. I cleaned and hopefully will put some miles on it this weekend and see what happens....
 
1 - 8 of 8 Posts
Top