Hardcore Sledder banner
1 - 3 of 3 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter · #1 ·
Just wanted to send a big shout-out to all who contributed to the following topic " http://www.hardcoresledder.com/forums/inde...howtopic=283334 ". First I set the offset (thanks to DonoBBD for the first class instructions) then I installed the Goodwin blue/orange spring with the shift assist (thanks to GuyFromTheNorth for the pictorial/tutorial). I know that this isn't everybodys pick but it is working badass in my sled. Personally I believe that each of our sleds is just alittle different from anothers (exhaust mods, manufacturer tolerences, weather at time of testing) therfore lots of different setups. Took it out yesterday and went across the 40 and what a difference, came right up to 7940 and stayed right there until 85 mph+, then backed off and jammed it again ran right back up to same and never climbed past 7980 till I ran out of field. Prior runs were at 8200 with major belt slippage and hot clutches with no backshift.

Without this site and all it's contributors I would be riding this sled and disappointed with it's performance without knowing why or how to fix it without some substantial bills to a tuner. I'm not a snowmobile mechanic just a tinkerer with a nice set of tools and the willingness to give it a try with a little instruction.

Thanks again to all and Happy New Year! Kevin
 

·
Registered
Joined
·
242 Posts
I'm given a ditto to Dono also, his tip about the shift assist and the Goodwin Blue/Yellow secondary spring woke my sled right up! Thanks to all you brain trusts out there!
 

·
Registered
Joined
·
53 Posts
i have to agree, this forum is great! lots of people here whit huge knowledge and they try hard to help others.

great jobb guys!
 
1 - 3 of 3 Posts
Top