Hardcore Sledder banner

1 - 5 of 5 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
looking for suggestions, I am new to the site but very impressed. My tach and speedo both jump all over the place. for example cant read at all at idle. and attempt max rpm and it said 11,010 in a 1000 ft. yeah right!!! checked both wiring harnesses at driven clutch and a steering linkage both are fine. Havent tried rotating coil yet I will if I am told someone else has done it and it worked. Second issue is a dim red light behind the temperture logo on the dash, can only see at night. Not really sure what that is for as the manual says alltemp problems should be addressed with the check engine light. this is lit wether the sled is ice cold or fully warmed up. I am stumped please help!!!!
Besides those minor problems I have about 200 miles on it and am fully impressed. This sled is a power house and I truly believe it will be a force to be reconded with.
thank you for your time

F7 sno-pro proud owner :D
 

·
Registered
Joined
·
867 Posts
Flip the coil over and reroute the wires. At high speeds the coil wires high freq. interfere with tach wiring which runs right past it. I have done this on 3 f5's. As for the light that is on, are you sure that it just isn't from the light which lights the back side of the tach.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #3
I hope so but doubt it as I have loked a three so far and compared they do not have the same dim light in the display. thank you for your response though.
 

·
Registered
Joined
·
1 Posts
Hey my f7 did the same thing Saturday night. I could only see it when my low beams were on. I am taking it in on thursday for updates and they say they will check it out. :eek:
 
1 - 5 of 5 Posts
Top