Hardcore Sledder banner

1 - 20 of 40 Posts

·
Registered
Joined
·
2,076 Posts
Discussion Starter #1
As post says, Does anyone know what the stock measurement might be on an 2018 xcr 800?
 

·
Registered
Joined
·
3,557 Posts
Local speed shop ported this sled, trying to verify it actually was done. Appears to not have been done. Still has a sand cast look.
This sled carries a back story worth telling, however the owner should post that once we determine what's been done.
I will say this the fix kit doesn't fix anything on the ho engine...
 

·
Registered
Joined
·
2,076 Posts
Discussion Starter #3
No need for measurements.. there was no porting done.. Good thing I payed priceless performance to port it... $3200 for junk
 

Attachments

·
Registered
Joined
·
2,076 Posts
Discussion Starter #4
Second time it locked up.. got bout 400miles out of it both times and before it went down..
 

·
Registered
Joined
·
2,076 Posts
Discussion Starter #6 (Edited)
Pretty pissed about Priceless screwing me.. long story short i called him about a bb kit.. instead he talk me into this kit that was supposed to be similar power and more reliable... well 800 miles and now 2 motors and he no longer reply back to me.. what's really sad is it wasnt any faster then stock.. payed him $3200 for nothing.. I think I put more miles on my boots walking g this passed winter then I did riding..
 

·
Registered
Joined
·
3,557 Posts
True story, no bs either. I pulled that pile of priceless junk out of the woods both times.

Unfortunately the story is worse than this. Slow turn around time to what might have been the all time slowest and poorly executed clutch set up I have ever seen. Really and nerd could have picked a better set up..
So stay away boys, I have held my tongue on this one long enough, he's had his chance to be a man and man up.
 

·
Registered
Joined
·
2,076 Posts
Discussion Starter #9 (Edited)
Promised me dyno time to tune this setup.. but that never happened.. wasnt faster then stock.. the stock Doo 850 would smoke me.. I payed priceless to pipe, port, head kit, and different piston to make my sled run.. he did all the work and it wasn't any faster then stock.. only thing fast about was how fast it went down
 

·
Registered
Joined
·
610 Posts
I had the same issue with another well known shops porting. mine ran great for the first 50-100 miles then would start falling off 400-500 miles max. Pistons look identical to yours. I was told it was from lack of lubrication even though I had extra oil in the gas along with the controller adding extra oil also.
 

·
Registered
Joined
·
2,076 Posts
Discussion Starter #11
I was told the same thing ( lack of lubrication) but the first time it went down he had a Polaris tech check the oil pump and he said it was good.. still went down again..
 

·
Registered
Joined
·
610 Posts
I was told the same thing ( lack of lubrication) but the first time it went down he had a Polaris tech check the oil pump and he said it was good.. still went down again..
I did the same also. original pump checked good but I replaced with a new pump just to be safe. 400 miles later the motor went down again.
 

·
Registered
Joined
·
107 Posts
What pistons are you guys using? I’ve ported a couple 800 ho motors without issue. The ones I’ve built are faster than the stock motors. I’m using stock pistons.
 

·
Premium Member
Joined
·
15,911 Posts
One of my friends did the same mod. It seized numerous times. IIRC, he finally determined that the shims were warped and created a part throttle air leak. Numerous fuel reprogrammings failed to fix it prior to that. Wasn't caused by the Wiseco pistons used.
 

·
Registered
Joined
·
107 Posts
Are you guys using shim kits or porting?

Jamie is yours hard on rings? Who ported it?

If you are ported did the person doing it cut the valves?
 

·
Registered
Joined
·
107 Posts
What pipes are you guys using?
 
1 - 20 of 40 Posts
Top