Hardcore Sledder banner

1 - 8 of 8 Posts

·
Registered
Joined
·
339 Posts
Discussion Starter #1
Had the new steering post put on and it hits even more with the new one installed. Anybody else had the same problem?
 

·
Premium Member
2014 XF800 137
Joined
·
4,042 Posts
I'm still in the same boat as you. Replaced steering post and still hits. Dealer just got 3 more and installed them in another sled and commented they were all bad. I finally took out bottom block which steering attaches to and put on a tach with the welder, this seems to work right now.
 

·
Banned
Joined
·
2,072 Posts
If you look at the service bulliten. It say's it may still hit the motor on a full turn right. How often are you going to do a full turn right? I will bet not very much.
 

·
Administrator
Joined
·
20,818 Posts
The real question is, how hard does it press against the cylinder? Mine touches, but it doesn't do anything to cause a problem.
 

·
Registered
Joined
·
339 Posts
Discussion Starter #6
mine pushes the mag side motor mount in about an 1/8". Long term damage is my concern.
 

·
Administrator
Joined
·
20,818 Posts
Then you've got a legitimate reason ... sorry to sound like I was doubting you Cajun. I've just heard a lot of people complaining, only to find out the steering post was causing no problems.
 

·
Registered
Joined
·
79 Posts
I found out from my dealer that AC parts dept was sending out the wrong part which was the bad one. They do have a new one but I did not hear how to tell them apart.
 
1 - 8 of 8 Posts
Top