Hardcore Sledder banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
I mounted mine left of the speedo/tach and plugged in behind speedo. Then I found the accessory plug behind the servo motor, I would rather plug there and run cord up handlebars to left grip. I had already drilled the hole in hood and mounted it!
 

·
Registered
Joined
·
899 Posts
i heard there is an aux. connector on the f7 but dont know where it is Help!
 

·
Registered
Joined
·
623 Posts
There are 2 accesory power plugs on the F7. One is up behind the headlights, the other is tucked behind the servo motor for the power valves. This one can be hard to see, but it's there. I ran mine up the steering column along the cables on the right side of the column. Since I usually wear a MX helmet, I tucked the end of the cable inside the tube that the riser block mounts to. You cant even tell it's there!!! It is pretty cool.
 

·
Registered
Joined
·
574 Posts
Discussion Starter #7
Thanks Adam12, found the one behind the servo. I'll use that.

I prefer the cord at the handlebars.

Arctic2
 

·
Registered
Joined
·
861 Posts
Arctic Cat TXI not fogging...................don't need a plug..................so far.


Kevin
 

·
Premium Member
Joined
·
207 Posts
Re: What ya got?

I relocated the fuel type switch to under the hood and used that hole as a mount for the shield plug.
Nice sled. I'm a polaris guy myself but I admit when a sled is sharp no matter the brand. How far up into NY? I ride near mayville.

Sent from my DROID BIONIC using Snowmobile.com App
 

·
Premium Member
Joined
·
207 Posts
Nice sled. I'm a polaris guy myself but I admit when a sled is sharp no matter the brand. How far up into NY? I ride near mayville.

Sent from my DROID BIONIC using Snowmobile.com App
Sorry didn't mean to put that in this forum. I don't know what happened there. Weird

Sent from my DROID BIONIC using Snowmobile.com App
 
1 - 11 of 11 Posts
Top