Hardcore Sledder banner
1 - 11 of 11 Posts

·
Super Advanced Member
Joined
·
4,101 Posts
How much was the head? How was the install?
 

·
Registered
Joined
·
3,175 Posts
Running the sled on the stand the engine seems more responsive. Has a different sound to it.
Had a couple of head bolt leaks, but were a easy fix. Now we need snow to test.[/b]
did u get the full billet head? or just the domes for the stock head? what did u use to plug your bypass line?
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #7 ·
did u get the full billet head? or just the domes for the stock head? what did u use to plug your bypass line?[/b]
Got the full billet cover and heads. 13:1 CR domes. A buddy of mine made a brass plug for the bypass hose.
RKTek sent me a cover where the two front head bolt holes were a machine tapered to use "O" rings under the head bolts
which I didn't get. Once I got "O" rings to fit(I used Artic Cat head bolt "O" rings), everything was all set.
With my compression guage I am getting 130 psi compression(cold engine).
Definately sounds way snappier on the stand.

Polaris9500,
Did you retorque your head bolts after you installed your head?
 

·
Registered
Joined
·
3,175 Posts
Got the full billet cover and heads. 13:1 CR domes. A buddy of mine made a brass plug for the bypass hose.
RKTek sent me a cover where the two front head bolt holes were a machine tapered to use "O" rings under the head bolts
which I didn't get. Once I got "O" rings to fit(I used Artic Cat head bolt "O" rings), everything was all set.
With my compression guage I am getting 130 psi compression(cold engine).
Definately sounds way snappier on the stand.

Polaris9500,
Did you retorque your head bolts after you installed your head?[/b]
yeah after i ran it a little iretorqued them but they were fine. u must have the first variation of his billet head because my head bolts dont have any o rings under them. i just put a little pipe dope under mine. i think mine is 120 psi hot
 

·
Super Advanced Member
Joined
·
4,101 Posts
Do you guys still like the head? Anyone running one without the front radiator?
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #10 ·
Definatley like the head. The engine runs way cooler. With the stock head under ideal conditions
the coolant was 130-140ish. 150-170 under poor snow conditions.

Now with RKtek under ideal snow conditions the coolant temp is 120ish, and in poor conditions the temp is 140ish.

Sled hads better midrange and overall better performance.

My radiator is still on.
 

·
Super Advanced Member
Joined
·
4,101 Posts
I took my radiator out and have put about 220 miles on so far. I'm going to put it back in do to the bad snow conditions.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top