Hardcore Sledder banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Recently put a trail can on my 2015 polaris pro s sled and noticed a check engine light after riding for a while. Would come on after a while and only after I gave a lot of throttle. Is this a egt sensor issue or what?
 

·
Registered
15 Pro-S/15 8RR/21 850 XRS
Joined
·
1,857 Posts
Which gauge do you have? I know the PIDD can show the code, just don’t remember the proper buttons to press to get the codes. Not sure if standard gauge can read view the code number. It will say in the gauge manual that you have. Maybe just a connector that you had to disconnect didn’t seat properly.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Which gauge do you have? I know the PIDD can show the code, just don’t remember the proper buttons to press to get the codes. Not sure if standard gauge can read view the code number. It will say in the gauge manual that you have. Maybe just a connector that you had to disconnect didn’t seat properly.
Just the standard gauge. I will look into how to read the code.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
standard gauge will also tell code but you cant shut it off to retrieve code and you will have to look in manual on which buttons to push new gas for this year ? no difference in power ?
Same gas, same oil, and no difference in power. Pulls hard. It would turn on after like 7000 rpm and shuts off as soon as rpms come down. The only change is the trail can so maybe I do some testing with the stock one.
 
1 - 5 of 5 Posts
Top