Hardcore Sledder banner

1 - 20 of 30 Posts

·
Registered
Joined
·
4,395 Posts
Discussion Starter #1
Just wondering how many people premixed the first tank of gas with oil?
I never did and now have 530 miles and no problems at all.
 

·
Registered
Joined
·
797 Posts
I ran 1 tank of premix and no problems. 625 miles so far. NO SNOW in wisconsin yet this year. Thats the biggest problem ive had this year!!!!!!!!!!!
 

·
Registered
Joined
·
125 Posts
why wouldnt you? its a easy thing to do.... I ran pre-mix then after two tank fulls ran injector cleaner through it and now I always start it up in ethanol mode until she is warm (just to be safe) and then back to regular
 

·
Registered
Joined
·
4,395 Posts
Discussion Starter #4
My dealer told me I didn't have to run pre-mix in the first tank of fuel with the F7 since it's fuel injected. I've hear the same thing from other guys. I just rode under 50 mph and varied the throttle during the first tank of gas. Zero problems after 530 miles.
 

·
Registered
Joined
·
899 Posts
I added 1/4 qt. to the first tank and some ISO. Even with that, it still got great gas mileage. Better than my friends Ski Doo's and Polaris'. I figured better to be safe than sorry. No problems to date @ 580 miles.
 

·
Registered
Joined
·
1,365 Posts
no premix in either, manual says do NOT do it with the F7. NO Problems.
 

·
Registered
Joined
·
720 Posts
I guess I didn't really have a choice. My dealer added it for me, and just told me to top the tank off. When I added my third tank of fuel, I also added some fuel injection cleaner. No problems here.
 

·
Registered
Joined
·
125 Posts
when you went to pick up your sled didnt it have a red tag around gas cap saying to run 1 tank of 100:1 premix? both efi's I have owned have, including the F7
 

·
Registered
Joined
·
26 Posts
I ran 100:1 premix for the first tank of gas and haven't had any problems. My F7 had the red tag on it that said to run 100:1.
 

·
Registered
Joined
·
127 Posts
OK, Quick question to the guys that added injector cleaner. Any special brand or any fuel injector cleaner will do?

Thanks
Bob
 

·
Registered
Joined
·
3,676 Posts
i don't know what kinda manual u guys have, but my owners manual says to run ONE tank full of 100/1, not more that one tank cuz it could clog the valves after that, i ran it with the arctic cat apv oil, no problems, with 550 miles. <_<
 

·
Registered
Joined
·
481 Posts
dealer said not to, but I put in 1/4 qt. anyway to be safe. It was -5 out so it might have helped. No problems though
 

·
Registered
Joined
·
942 Posts
Mine was already in the tank. I think it causes sticky power valves. I cleaned mine last night. Gee, that was fun :p . Especially taking out the the three allan headed screws. Rounded out two of them. :(
 

·
Registered
Joined
·
50 Posts
Dealer had 3-5 gals of premix in tank when I picked up sled. Rode 11 miles and filled the tank, no problems other than smartvalve....
 
1 - 20 of 30 Posts
Top