Hardcore Sledder banner

1 - 20 of 36 Posts

·
Registered
Joined
·
2,401 Posts
Discussion Starter · #1 ·
I JUST INSTALLED MY PRESSURE REGULATOR AT IDLE ITS 42 PSI A WOT ITS 38 AND THATS WITH THE REGULATOR ALL THE WAY OPEN WHAT IS IT SUPPOSE TO BE?
 

·
Registered
Joined
·
4,259 Posts
Like DTR and some others have said, 05's tend to be a little leaner from the factory. I would take the Restrictor off and sell it to someone with an 03-04 which tend to be a bit richer.

JMHO

mike
 

·
Registered
Joined
·
2,401 Posts
Discussion Starter · #5 ·
let me see what the new gauge reads first bikeman thinks it could be the gaugei f its not the gauge and my pressure is that low i will sell it and get a boondocker because im going to have to add a little fuel with the pipe mod
 

·
Registered
Joined
·
412 Posts
Is this the key to slow 05's???????? You said you have a fast one (I believe in your other post) one that will go over 100 mph and you have now confirmed you are somewhat lean on top (new gauge will confirm) You didn't make any clutch mods or did you? What I don't understand is why some are fast and some are not some say 05's are rich on top yet I've also read they are better then the 04's and 03's. I am just a novice but I would think that the machining of clutches and the set-up from the factory might be more of a constant from sled to sled then the fuel mapping???? I don't know :dunno: I have yet to ride mine so I don't know if I have a fast or slow one????Or is there really even such a thing as a fast or slow one?????What is the date of build on yours if you don't mind me asking? Thanks
:beerchug:
 

·
Registered
Joined
·
2,401 Posts
Discussion Starter · #8 ·
MY SLED IS BONE STOCK NO STUDS NOTHING! JUST EYE CANDY,NO PERFORMANCE MODS UNTILL NOW. MY SLED DID SLOWEST ON GPS WAS 102 ON POWDERY ICE. AVG WAS LIKE 106-108 FASTEST WAS 111 ALL ON GPS. TODAY WHEN I PUT THE FUEL RESTRICTOR GAUGE IN IDLE WAS 42 AND WOT WAS 38 I THINK THATS A LITTLE ON THE LEAN SIDE I DIDNT TURN THE RESTICTOR DOWN AT ALL ITS ALL THE WAY OPEN. I CALLED BIKEMAN AND HE IS SENDING ME A NEW GAUGE TO CONFIRM.
 

·
Registered
Joined
·
2,321 Posts
my 05 has a build date of november 4th and it wont even do 100mph even after messing with the secondary.... its also over revving....

i dont understand how some are fast and some arent.... but i do know that the secondary update works and have yet to hear of a sled that this didnt fix its issues...
 

·
Registered
Joined
·
2,401 Posts
Discussion Starter · #10 ·
MY BUILD DATE IS 11/04 AND ALL MY SYMBOLS ARE SQUARE ECU, TB,AND INJECTORS. MINE REVS TO 8100 AND SETTLES TO 8000. MAYBE THE GREEN ONES ARE FASTER :dunno: :fluffy: :fluffy: :dance2: :smiley-faces7:
 

·
Registered
Joined
·
412 Posts
Originally posted by zr8guy@Sep 13 2005, 08:28 PM
my 05 has a build date of november 4th and it wont even do 100mph even after messing with the secondary....  its also over revving.... 

i dont understand how some are fast and some arent....  but i do know that the secondary update works and have yet to hear of a sled that this didnt fix its issues...
<div align="right">index.php?act=findpost&pid=873702
[/quote]
Have you ever checked your fuel pressure? My build date is 07/04 I am assuming you don't get full shift-out? Are you a big guy?
 

·
Registered
Joined
·
412 Posts
Originally posted by DR F7@Sep 13 2005, 08:32 PM
MY BUILD DATE IS 11/04 AND ALL MY SYMBOLS ARE SQUARE ECU, TB,AND INJECTORS. MINE REVS TO 8100 AND SETTLES TO 8000. MAYBE THE GREEN ONES ARE FASTER :dunno:  :fluffy:  :fluffy:  :dance2:  :smiley-faces7:
<div align="right">index.php?act=findpost&pid=873712
[/quote]
What do the symbols mean? Do you get full shift out? Are you a big guy? Maybe the green ones are faster LOL... I have seen one on a lake for its first run and it was fast straight from the dealer and broken in like it was a rental.
 

·
Registered
Joined
·
4,259 Posts
Couple things DRF7...

1.) You should not need to add fuel with the BMP pipe mod (or atleast MOST sleds should not). Your sled does seem a bit lean for stock, but I think you should be more then safe with the BMP pipe mod, but I guess Erich would know best.

2.) If your sled is reving that high, I would definitely looking into some clutching mods pronto. That is awful high for a stock sled RPM-wise. When you add those mods you will be pulling a rediculously high RPM.

JMHO

Mike
 

·
Registered
Joined
·
2,401 Posts
Discussion Starter · #16 ·
Thank you mike. I did speak to Erich and we are taking care of the clutching too. There may be somthing up with this engine Im not sure if it is just the psi or if its one of those stock hot engine I got lucky with. I have not touched anything whithin it untill today. The new gauge will help. A friend of my cousins has an 03 f7 and said he couldnt believe how much harder my sled pulled then his,maybe it was just the track. :dunno:
 

·
Registered
Joined
·
899 Posts
i have the same set-up. and i have the psi 42 at idle and 38 wot.. but my sled wont go past 95???
 

·
Registered
Joined
·
2,401 Posts
Discussion Starter · #18 ·
That sucks alot of guys cant hit 100 on there f7 check to see where your shift out is.
 

·
Registered
Joined
·
899 Posts
i am gonna be doing the D&D clutch mod. if that dont work? i am going to burn the sled
 
1 - 20 of 36 Posts
Top