Hardcore Sledder banner

1 - 7 of 7 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1

I have a F5 SnowPro, it uses a quart of oil every 60 miles and when you start it
it idles at 2000 rpm's then when I ride it and stop for a stop sign it will idle down to 3500 no lower. If I shut it off and start if up again it idles to 1900. Which is fine!!! It seems like something is hanging it up!!! And No top end.....
75 to around 80 now. I jet it down to 370 and it seems to make it worse.
 

·
Registered
Joined
·
6,125 Posts
Have your oil pump adjusted-dealer should do for free-60-1 to 70-1 oil ratio your shooting for

Pull off your servo motor cover-cables probably fell off

Go back in time on this board or do some research in the old archives on search menu-these subjects go back to the stone age-honestly the apv cables and oil issues on f5s are their main problems-other then that i love the sleds-scott
 

·
Registered
Joined
·
1,122 Posts
I can go about 95 miles on a quart of oil with my F5.
 

·
Registered
Joined
·
6,125 Posts
Guys i average about 12-13 mpg on both my f5s-main jets on wifes at 370s-mine at 360s-anyways say you average 12 mpg

60 miles to a quart-ratio of 20-1-plain sick-one of mine was at 25-1 until it was adjusted-now at 60-1
90 miles to a quart-ratio of 30-1-not good-both should have your oil pumps adjusted

60-1 to 70-1 is a good average unless you love buying oil and having your oil light come on at 100 miles-scott-remember these are averages,i dont know your exact mpg and if your at wide open throttle most of time,but still your running alot of oil in my opionion
 

·
Registered
Joined
·
6,125 Posts
Sorry 95 miles about 32-1
 

·
Registered
Joined
·
280 Posts
Mine idles a litle high for about 15-20 sec then droops to 1850rpm, i think it's supose to do that so you can se the digical tac when you are standing still, when it idles 1850 it's not enuff power for the digitals. :huh:
Regarding the oil mine has dropt in the oil usage so now it's at 2,5% thats ok i think.
 
1 - 7 of 7 Posts
Top