Hardcore Sledder banner

1 - 8 of 8 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
I haven't ridden my F5 at all last week and it was fine then. Attempted to put v-forces 3's in it on saturday night but only got as far as taking the pipe off. Sunday afternoon would only shift out to 7920-7940 RPM's down wind and 7400-7500 up wind. This thing used to be an animal before, why can't I shift out to 8400?
 

·
Registered
Joined
·
341 Posts
Discussion Starter #2
OK, it could probably one of three things.

#1 it could have been too rich (stock jetting) and it was kinda warm, could this limit RPM?
#2 I didn't put any pipe sealant on when I replaced the pipe, also the pipe may not be seated properly.
#3 The EPTS cable may not be plugged in all the way.

I was also told that I'm spinning weights that are too heavy for the primary, but they're stock at the sled was perfect before last weekend...
 

·
Registered
Joined
·
341 Posts
Discussion Starter #4
OK, I talked to my dealer and before I said anything he wanted me to bring my sled in for updates. I know the heavy duty handlebar clamps are one of them, I broke both sides now, and probably the oil resevoir update. Am I able to take the nut off to take the EPTS off (right near the pipe) or is it safer to unplug it?
 

·
Registered
Joined
·
236 Posts
Are you talking about the exhaust temp sensor or something else. Im running into the problem of loss of speed. Although my sled is turning 8350 max spped is 85 mph. Can't figure out what is wrong. had reverse added but can't believe i will loose 15 mph. Doesnt seem to be as responsive either.
 

·
Registered
Joined
·
287 Posts
Our F5 will do 98mph on the speedo @ 8500 rpm in 3/4 of a mile run .
When removing the pipe you are better off to disconnect the electrical
connection . :D Did you install the Vforce reeds ? If so check, maybe
you will need to rejet . We dropped 2 sizes on the mains .
 

·
Registered
Joined
·
341 Posts
Discussion Starter #8
I didn't put them in yet, I wanna tear it down to check it out, but I was using my buddies garage and didn't wanna spend too much time there snooping around my sled. I'll wait till I recieve a couple other mods and install them all at once. I just got my 6.44" risers in, those will go on saturday fer sure...
 
1 - 8 of 8 Posts
Top