Hardcore Sledder banner
1 - 5 of 5 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter · #1 ·
I bought a new polaris belt last week. I put about 300 miles on it and it tore out 3 teeth. It looks like it pulled apart from the belt could that be from the forming of it? Anyone else have this happen? Kind of pissed out $80 bucks
 

·
Registered
Joined
·
267 Posts
I bought a new polaris belt last week. I put about 300 miles on it and it tore out 3 teeth. It looks like it pulled apart from the belt could that be from the forming of it? Anyone else have this happen? Kind of pissed out $80 bucks[/b]

Take it back when you get a new one and try for warranty... if not get at least 20% off a new one
 

·
Registered
Joined
·
6,369 Posts
how hot are your clutches ? If you cant put a bare hand on them for 10 seconds it to hot. I like to keep mine 100 ~ 140*f for max operating temp , this is after 10 mins of riding and a few drags up and down the lake. When was the last time your clutches where removed and cleaned and inspected, should be doing this every fall.
 

·
Registered
Joined
·
190 Posts
Discussion Starter · #4 ·
Just cleaned them. Could it just be from running it hard or it just hooking up hard. I have 1 3/8 studs up the middle and it puts the skis in the air but I was just trail riding around 50 to 60 mph. My last belt had 1800 miles on it. Oh well just was wondering if maybe just got a bad egg.
 

·
Registered
Joined
·
1,406 Posts
Just cleaned them. Could it just be from running it hard or it just hooking up hard. I have 1 3/8 studs up the middle and it puts the skis in the air but I was just trail riding around 50 to 60 mph. My last belt had 1800 miles on it. Oh well just was wondering if maybe just got a bad egg.[/b]
did you check deflection before rideing? did you clean new belt? did you break in new belt right?
 
1 - 5 of 5 Posts
Top