Hardcore Sledder banner

1 - 6 of 6 Posts

·
Registered
Joined
·
841 Posts
Discussion Starter #1
My F7 is pissing me off.. one day it works perfect the next day it wont hold peak rpm.. The sled works good at 1/4 - 1/2 throttle but when I give it hard the rpm hits 7900 but falls to 7400-7500 and the needle on the analog guage flickers up and down a little... Sometimes the sled is real bad and bogs down to 5000rpm and feels like its missing and drowning in fuel and I will shut it down and it kind of clears up ..but not 100%...Its not the power valves because I checked them..Any Ideas cause my dealer is a goof and doesnt want to help..
 

·
Registered
Joined
·
1,236 Posts
Had the same problem, Dealer replaced my stator and that was the fix for mine. Just to let you know the stator tested fine but was still faulty.
 

·
Premium Member
Joined
·
3,765 Posts
mine did the same thing one day, ...i was going nuts......
then i remembered to put the isopropyl in it.
i put it in every tank......no problems anymore.
 

·
Registered
Joined
·
841 Posts
Discussion Starter #5
Every tank of fuel I use gas line antifreeze for the same reason..and if I skip a tank sure as sh1t the smart valve ices up...my dealer did do a test on the stator and said it checked out....Are they known to work perfect for some time and then act up ?? I am getting on the phone this morning with a new dealer because my dealer outright told me that they dont get paid for diagnostics and he will not spend time on my sled unless I am willing to pay..The last time I had it at the dealer for this problem he gave it back to me not working and said it was fine...
 
1 - 6 of 6 Posts
Top