Hardcore Sledder banner

1 - 20 of 23 Posts

·
Administrator
Joined
·
20,853 Posts
JS ... don't feel bad, I'm in the same boat. A lot of the guys will say it's a matter of conditions (which is true). But I was in excellent conditions recently ... hardpack, no wind, about 10-15 degrees, and could not get more than 98-99 mph. My tach was set to digital mode and I hit 8040 RPM, so that appears to be a little high. Belt deflection is good (about 1 1/4") and the track will actually creep at a rate of 2-3 MPH when on a stand.

I'm thinking about changing the helix, and would be interested to see what you find out.

Chris
 

·
Registered
Joined
·
534 Posts
You might want to check your Powervalve cables per instructions elsewhere on this site to see if the valves are within spec.
 

·
Registered
Joined
·
1,245 Posts
Its only geared to go 90mph with the sprockets its got on their now (19/40). Mine goes about 93on the speedo and when I raced a MXZ600 he said his speedo was hitting 107. We ran the mile long run and he was only about a sled or two in front of me. We had the same top speed. Just goes to show you how much more accurate the digi speedo is.
 

·
Registered
Joined
·
244 Posts
I talked with a Black Magic Tech and he was telling me that I should be between 8000 and 8100 RPM for max HP. I'm running 7910 max RPM and top speed of 97 mph with std F7. He told me to check the APV's to make sure they are adjusted right. I inquired to them because earlier in the year there tests were 117mph in a 1/2 mile and 114 in 1000 feet on a lake, (with little snow if any,found this out later).Have'nt check my cables yet tho. Will next time I go up and post if any differance.
 

·
Premium Member
Joined
·
10,637 Posts
My F7..which I have set up well....One day 110 plus next day 98mph...need to race to know..All in the snow, for sure :D

I have tried to get it to go faster on the slow days..nothing works..bad snow..
 

·
Registered
Joined
·
2,515 Posts
Originally posted by The Outdoor Shop@Feb 11 2003, 10:45 PM
My F7..which I have set up well....One day 110 plus next day 98mph...need to race to know..All in the snow, for sure :D

I have tried to get it to go faster on the slow days..nothing works..bad snow..
Yup, I think you said it all right there. Comes down to the ever-changing conditions -- snow, ice, wind, humidity, altitude, temps, driver weight, gas level, motor broken-in, motor worn out, and too many other little things to even begin mentioning! -- Roy
 

·
Registered
Joined
·
3 Posts
Discussion Starter #12
Originally posted by jssled@Feb 6 2003, 10:33 PM
Was racing on river and couldn't get over 93mph. Has any one else experienced this?
Have been riding more, was out on a 5 degree day got 109 out of it also noticed that trottle cable could be snugged up some. Thanks for all the input. :p
 

·
Registered
Joined
·
485 Posts
:lol: I've observed everything between 93 and 116 mph top end, seems to really vary with conditions. If it makes you feel better when mines slow all my riding buddies are slow too. :)
 

·
Registered
Joined
·
8,701 Posts
rode my buddies f7 yesterday... had it to 104 on the lake.. next trip 102 to 103... he got on it ,, hit 99mph and it shut off... then wouldn't go over 30 mph. sat for 5 mins and would only run at 99 again. another friend of ours has an f7 that pulled 113 on the digital speedo, and walks by this f7 handily. anyone else heard about these things shtting down like that?
 

·
Registered
Joined
·
8,701 Posts
he bought it late in the season, i think all updates were done.. as for the temp gauge, i didn't even see one..lol taking it back to the dealer this am. i'm a die hard cat fan, but this sled and all the problems i'm hearing about it is really disheartening. oh. as for theguy who was getting beat by that mxz600... somethings wrong with that sled.
 

·
Registered
Joined
·
2,180 Posts
I have had mine up to 116 on a road on ideal condition's ..it will do 105-107 on the groomed trail's all the time......it turn's up 8020-8040.
 

·
Registered
Joined
·
395 Posts
I,ve got just over 1,000 miles on my F7sp and I've never seen anything above 100mph. Did get Goodwin clutch kit which has max rpm at full shift of 7700rpm. Also added D&D pipe, BM canister , vf3 reeds, and +3 timing key, still only 100mph. The sleds a frickin' rocket from stand still!! Doesn't matter, I'm upgrading to D&D's tunable EFI F8 kit, need more speed. ;)
 
1 - 20 of 23 Posts
Top