Hardcore Sledder banner

1 - 5 of 5 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
Hi, I have a 2002 ZR440 and from day 1 the speedo never worked. I bought a smaller magnet and now it works intermittently and its really jumpy. The part number of my speedo is 0620-258 revision C.

I bought a newer one off someone on here and its part number is also 0620-258 revision F. Now the speedo doesnt work at all, with the small magnet.

Is there something I'm missing? What do I have to do to get this speedo working, I see on brown's leisure world that there is an updated part number 0620-284 speedo, is that what I need?

If so who can I contact at Arctic Cat to get a replacement, would I be able to ship back the original one to your attention and get the proper speedo?

Thanks very much!
 

·
Registered
Joined
·
141 Posts
Discussion Starter #4
I would have thought the Revision F is the updated one, it has a 1 year newer date code on it too.

There no cable, its electronic like the firecat speedos
 

·
Registered
Joined
·
47 Posts
lbz351

If you purchase the sled through the race dept, I would try to contact them. If not, the only other way to discuss this with someone here would be through your dealer, or customer service I believe. I really havn't kept up much on the speedo updates, as that development takes place in the electrical group. if you can't get anything done, I could try to get more info from the electrical group. But it would have to wait until later as I am pretty busy wrapping up my work here.
 
1 - 5 of 5 Posts
Top