Hardcore Sledder banner

1 - 5 of 5 Posts

·
Registered
Joined
·
514 Posts
Discussion Starter #1
Headed out riding today and about 5 miles into the ride the speedo and tach on my husbands F7 went dead. If you let it sit and idle for a few minutes it would come back on but go dead again as soon as you started to ride. Then about halfway into the ride the sled starts to choke and spit, and the check engine light starts to flash.

We pull over, check the wires , change the plugs.. nothing noticeable out of wack. Start sled, the light doesn't come on so we start to ride... all is fine now except for the speedo.

Now its getting dark, and soon enough we realise that when you hit the throttle the lights dim, as does the brake light. Let it idle down and they brighten right back up. Back to the trailer we go... 24 miles short of hitting 1000.

Obviously there is some sort of electrical short that is messing with everything. Have any of you encountered this before? Need to get it corrected tonight so we can ride tomorrow.

Any insight???


Thanks guys,
Rebecca
 

·
Registered
Joined
·
831 Posts
i'm far from being an expert but it sounds to me like you may have a coil or stator problem. no easy fix i don't think.
 

·
Registered
Joined
·
3,411 Posts
dingoblu,

Check the wire harness behind the secondary clutch that is right next to the APV servo motor. If memory serves me correctly, others were having similar problems like yours from the secondary cluch rubbing this particular wire harness due to the harness not being zip tied back/away from the secondary clutch when it opens up at speed/throttle. Let us know what you find when you look at this area....
-John
 

·
Registered
Joined
·
514 Posts
Discussion Starter #5
Thanks guys.... checked all the wiring, didn't find any bad spots. Have to take it back in anyway for the smartvalve update... they are on backorder too. Seems like we are always dragging them back for something, nothing like a 2 hr drive in the mountains ;)

Been snowing since yesterday, got over a foot locally.. should be getting hammered in the mountains. Might as well go and see if it will run today.
 
1 - 5 of 5 Posts
Top