Hardcore Sledder banner

21 - 27 of 27 Posts

·
Registered
Joined
·
118 Posts
Oh, I also wanted to add that I was struggling a bit with the flathead to get the valves apart. I used a pair of needlenose pliers to pinch the little clips that hold the valve together, and that worked very well.
 

·
Registered
Joined
·
3 Posts
Great post. Worked on my 2012 f1100t. Was experiencing bog and backfire at low throttle with hard acceleration with less than 1/2 tank of fuel. Moved vented valve as stated above in less than hour. Thanks for saving me a bunch of time and get my sled back on the program. Boost on...
 

·
Registered
Joined
·
860 Posts
I was out yesterday and started getting a surging (bucking) at slow speed after about a 80 miles of running. Seemed to go away once you got it opened up. Once I got closer to the truck (running slow speed) it came back and started getting real bad, then to the point where it would stall . Does this sound like the same symptoms of the fuel valves ? :dunno:

QUOTE=blown 5.0;8973777]Is this like a bog or bucking when you get near half tank?

Sent from my SCH-I535 using Snowmobile.com App[/QUOTE]
 

·
Registered
Joined
·
2 Posts
Guys, i know this is an old thread now but i had issues with my fuel and pump with only like half a tank consumed. the pump would whine like crazy on uphill or downhill. i took it to the dealership "it's all good! nothing wrong" and it whined right after i took it from them. the rubber washer part of the valve slid off the bigger diameter part of the plunger at the bottom of the spring. the washer was riding up the spring, so even if the valve opened and there was fuel there, the vacuum of the pump would still hold the rubber washer up.:glare:

i pushed the washer back down onto the tapered part of the valve and hopefully its all good. also swapped the vented one to the front.

I read elsewhere that people were replacing the spring with a Bic Pen spring. the Bic spring constant is way too big compared to the stock one. i would not recommend it. chances are it would hold the valve open all the time. its a lot of force to close it.

good luck!
 

Attachments

·
Registered
Joined
·
789 Posts
I just swapped in the new valve assembly today. The vented and non vented are in the same spots as stock 2012 800 were. The two valves are closer together in the back. I just fed them back in and fell into place it looked like. My question is how can these not go into the right spot where people need to put arms into tank and place them? Im curious as to it going together so smooth. Has anyone had tp do the fix or updated springs on the 2014-2016s or was this a 2012-2013 prob? Thanks
 
21 - 27 of 27 Posts
Top