Hardcore Sledder banner
1 - 2 of 2 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Something happened on my 03 F7 today. It sounds like something kind of catching in my forward/ reverse drive. This happens while I drive forward. I drove home 3 miles today going about 10 MPH because I didnt want to worsen the problem. It will go faster, but I didnt want to risk it. Also three times I was driving about 10 and all of a sudden the gears started making noise and it stopped. like it kicked out of gear. So I put it in reverse and then forward and kept going. At one point it wouldnt go forward, but it finally did. When I got about 3/4 of a mile from home the noise seemed to stop.

Any ideas?
 

·
Registered
Joined
·
670 Posts
Something happened on my 03 F7 today. It sounds like something kind of catching in my forward/ reverse drive. This happens while I drive forward. I drove home 3 miles today going about 10 MPH because I didnt want to worsen the problem. It will go faster, but I didnt want to risk it. Also three times I was driving about 10 and all of a sudden the gears started making noise and it stopped. like it kicked out of gear. So I put it in reverse and then forward and kept going. At one point it wouldnt go forward, but it finally did. When I got about 3/4 of a mile from home the noise seemed to stop.

Any ideas?[/b]
Hi, when the lever is not adjusted right it will cause this problem. When I first install the kits they do that because the throw of the lever is not adjusted. Once its adjusted they work fine. May not be the problem, but its a easy place to start.
 
1 - 2 of 2 Posts
Top