Hardcore Sledder banner
1 - 4 of 4 Posts

·
Registered
Joined
·
15,182 Posts
Discussion Starter · #1 ·
Well, finally this last weekend got my sled out on the trail. Rode/felt pretty awesome finally getting back out. I had allready put on approximately 125 miles before this trip.

But, the first ugly, rode 5 miles into town where I met FLY_HIGH_F5 to finish off his bullshit about his F5 kicking my ass. Well, took care of that one right away on the lake when we dragged. But, I do have to say that little 500 does have some balls. But anyway, I check my speedo and im still pulling on him slightly at 80 when all of a sudden I hear a loud BOOM. Well, initiallythe worse comes to mind that I threw a rod, blew a piston, blew a clutch, etc. But, I stopped and it still ran as I slammed the brakes so once it came to a stop I shut it down. Well, my belt took a shit and did a little damage along the way. Put a nice dent in my beltguard but worse put a really big crack in my shock tower. :banghead: Whatever, shti happens. it makes me mad mostly because now I cant watercross without really worrying about my clutches getting wet. But I think a few frankenstein stitches will solve the bellypan for now.

Then later in the day I screwed up my speedo cable. Not sure what happened yet but I think all that happened was the key had broke. It was on a soft landing on a jump it happened on. So I thought maybe the bearing was taking a crap, btu I couldt seem to wiggle the driveshaft at all so I think it should be ok. Still have to investigate on this one though whenever I get time.

Otherwise, I had fun, found a small puddle in a field to play in for awhile.
 

·
Registered
Joined
·
15,182 Posts
Discussion Starter · #4 ·
Im pretty sure the downfall to my belt was a lot of wear and tear. I would guess it had around 3,000 miles on it, but Ihavnt been really nice to it lately. The day before this happened I had been riding on the lake which had 2-3 inches of water on top of it. Im sure I got quite a bit of water on the belt so it probably tore it up a lot. Its just too bad that it had to blow at such a high speed and do the damage that it did.

But, im not sure wy the speedo went out. Whenever I get time to investigate it ill be doing that. Hopefully soon.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top