Hardcore Sledder banner

1 - 6 of 6 Posts

·
Registered
Joined
·
200 Posts
Discussion Starter #1
First my digital display started cutting out at idle 200 miles ago. Then my hand warmers about 100 miles ago, and now my headlights barely light up unless on steady throttle. As soon as I let off the gas, or put on the brakes, or hit a big bump, they dim out 90%. Dealer has ordered a voltage regulator, but I'm beginning to think this is may also be a short somewhere. Anyone else experiencing these symptoms?
 

·
Premium Member
Joined
·
7,417 Posts
check your grounds. there is a ground wire near the mag that people have been saying it breaking

 

·
Registered
Joined
·
206 Posts
Biggestcat, Have your dealer check the drive shaft bearing on the PTO side. If it has walked out at all it would cause the same types of things. He should be able to check it when he's replacing the voltage regulator. NOT saying this is the issue, just something to check to make sure it is not the problem. Good luck! .600 liter :lol:
 

·
Registered
Joined
·
200 Posts
Discussion Starter #4
Checked the grounds, and they're okay. I just found out that the voltage regulator is on back order until mid April!!!!!!!!!!!!! Wonder if a regulator from another model would work without causing problems with the ecu?
 

·
Registered
Joined
·
773 Posts
I had the same thing happen, my left handwarmer element shorted to ground.After I shut the handwarmers off everything was fine.I have since replaced the element & everything is ok.
 
1 - 6 of 6 Posts
Top