Hardcore Sledder banner

1 - 4 of 4 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter #1
Just under 500 miles. Warm sled up properly every time out. Premix in first tank....switch in ethanol mode... All updates done. Sled has good power from 0-60 but not as good as I expected compared to my 99 zr 600 efi. After 60 mph the power seems to drop off...however the sled will eventually reach 90-95 mph. The conditions were ideal -10 to +10 and hard & fast trails. Im not an expert & would think the sled is capable of a lot more. People are talking about adjusting the valve cables, throttle cable, adjusting the clutch, loosening the track etc.etc.etc....all of this tweaking to get the sled to run over 100.... If I had known it was going to be this bad I would have never bought the sled. To top it all off I pulled the pipe off yesterday & took a look at the pistons...noticed some scratches....WTF!!! I have babied this machine...with a full understanding of motor issues. My dealer is 2 hours away...hopefully he will get this thing fixed...without charging me an arm & a leg! Thanks for the help.
 

·
Registered
Joined
·
2,180 Posts
He should not charge u any thing it is all under warrenty!!!!!!!If u have a compression gague should check it.I have no proplem getting speed out of mine...105-107 on the trail's all the time.....115 on hard packed road.Maybe ur power valves are not opening?What size track do u have the sno-pro are not as fast on the top end but they dont have any proplem geeting 100 or better...did u run against another f7??What are ur rev's?
 

·
Registered
Joined
·
8,701 Posts
sounds like she popped on ya. been doing that alot this yr. buddy had his back by the end of the day when he took it in to get fixed. they had the cylinder and piston and rings just waiting for it...lol
 

·
Registered
Joined
·
26 Posts
This weekend my f7 was not pulling very hard at all on top end and by the end of the trip it would only go 85. My pipe was cracked. Won't be able to get a new one till next week so I don't Know if that is the problem or not, just something to check.
 
1 - 4 of 4 Posts
Top