Hardcore Sledder banner

1 - 9 of 9 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
Only got 1300 miles on F5 due to lack of snow. Anyone get fairly high mileage and what if any problems? Only problem I had was a gunked up servo cable.
 

·
Registered
Joined
·
6,125 Posts
About 2500 on the red f5
About 1500 on the black f5
About ????? on the zr500-Cant remember before i sold it!!!
I wish i would have kept track on how many miles for me as i was driving all three along with the wife-That didnt sound good

Anyways other then oil consumption and apv cables(Everything appears to be fine now once new cables and oil ratio set),both sleds worked great-As a matter of fact im sandblasting and trying some new exhaust paint that we use on airplanes-All pistons and cylinders look awesome!!!!!!!!!!!!
One more thing ice under seats which is also fixed and working great-Scott

I guess nothing major which kept me from riding so i shouldnt complain to much!!!!!!!!!!!
 

·
Registered
Joined
·
37 Posts
4000 miles. Sounds like you had some issues, but couldn't have been too many show stoppers with that kind of miles.
 

·
Registered
Joined
·
2,913 Posts
f-5 sno-pro

2600 miles
worse issue i got was the chaincase leak, but now its fixed , dealer replaced bearings with a different style per cat .

had the normal updates, below is the list of little stuff
1 idler wheel bearing
kill switch fell apart
front suspension arm in the rear was replaced because the curvey wire thing fell off
seat cover had small tear
and i think that was it ! the sled never broke down or left me stranded , it was a blast !
the main thing i can say is that EVERYTHING was warrantied by cat with no problems and i was never "without " my sled for more than a day . would i buy another one? depends on what is out on the market at the time im ready to buy, im not brand loyal at all, trust me. B)
 

·
Registered
Joined
·
530 Posts
almost 1000 miles a lot of problems.

Broke sprocket and chain.
Powervalves never stayed on.
Always getting updates done.
Carb rail broke.
Wouldnt run for a while. Mostly from bad gas so not really cats fault.
And there was a few more smaller things that didnt matter much
 

·
Registered
Joined
·
282 Posts
3720 Miles, dealer did all updates before I picked up sled so it ran pretty good all year. I never had a problem with my servo or cables, but had to clean the valves a couple of times.

The problems that came into play from milage were:

1: I replaced all idler wheels. This is an area that needs to be upgraded for next winter.
2: The seat cover ripped in the lower front and I think everyone will have this problem due to a piece of
plastic rubbing against the seat.
3: One of my slide rails cracked underneath the big nut. (see robs post for a picture)

As with any first year production sled I expected a fair share of problems. My dealer assured my that AC would take care of all the problems. I for would buy another F5.
 

·
Registered
Joined
·
276 Posts
3500 miles and no problems so far. the only complaint I have is that it used too much oil but I solved that. I saw 104 on the speedo. I thinks that it is very impressive for a 500. This is my second first year sled/motor from arctic cat. All I can say is I can't wait for my next one.
 

·
Registered
Joined
·
1,245 Posts
Black F-5, 1680miles - 66hrs.

No problems, need the update done that has to do with wrong info on the Tach. It would read 10,000+ RPM's on both digital, and the "old school" tach.

O well, still my best year ever with miles. Great bump sled!
 
1 - 9 of 9 Posts
Top