Hardcore Sledder banner

1 - 5 of 5 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
I was just looking under the hood of my F5 Sno Pro, and there are a bunch of small round oil spots all over the engine and surronding areas. The sled is running great. It seems to be using alot of oil, I've almost used up a gallon of oil (tank is almost full right now) in about 230 miles. I cannot see where it could be comming from. I checked the Chain Case, and it's still full.

I have a picture, but I fogot my USB cables for my camera at home, I'll post them when I get a chance.

Is this normal? Or is there something wrong? Any ideas? It looks like oil, but I'm not sure..
 

·
Registered
Joined
·
696 Posts
I know lots of us have had an exhaust leak, which makes a mess of things...usually around the clutch cover, carbs, etc. Some have been worse than others. Leaves a sticky, oily residue all over. :eek: If that's the problem, it will probably seal itself. As far as oil usage...my dealer starts looking into mine at 8:00 Monday morning. I am using waaaaaay too much oil too! :wacko:
 

·
Registered
Joined
·
534 Posts
We're probably getting about 400 -500 miles on 2.9 quarts of oil (Three tankfulls of gas).

Your using to much oil. Have it checked at the dealer.
 

·
Registered
Joined
·
6,976 Posts
I'm sure it's an exhaust leak. Should seal itself and it probably only does it when the motor's cold.
Cat S.
 

·
Registered
Joined
·
1,936 Posts
I had the same problem. Took off the pipe and put some ultra copper rtv around the donut where it seals on the pipe. Ran it and it still leaked. I took it off again and put some on the inside of the donut where it seals on the manifold- problem solved.
 
1 - 5 of 5 Posts
Top