Hardcore Sledder banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3,719 Posts
Discussion Starter #1
My dealer told me to bring the sled back to them after 250-300 miles,for an after break-in inspection.I didn't take it back to those Jokers,and am just wondering if anybody else was told the same.Did you take it back to them?Is there any way AC wouldn't warranty my sled because I didn't go back for the inpection?I've done all the updates myself,with my own fixes and have NO real problems after 1500 miles.Thanks for your input-Jason
 

·
Registered
Joined
·
244 Posts
No , my dealer just took my money and did'nt even say good bye or thanks when i left!!! :unsure:
 

·
Registered
Joined
·
3,719 Posts
Discussion Starter #3
Same here-Sales department was awesome,very friendly and informative-service department sucks,rude and un informed jerks.I'm very disappointed in Track Side of Eagle River.I only wish I had spoke with the Morons in the service dept. before I plunked down 8000$ in the sales dept.Live and Learn,I just wanted to make sure my warranty was still good,Thanks
 

·
Registered
Joined
·
2,515 Posts
Originally posted by herm@Feb 11 2003, 10:15 AM
No , my dealer just took my money and did'nt even say good bye or thanks when i left!!! :unsure:
LOL! No shit -- seems like some of us are treated better after buying a gallon of milk at our local c-store or Wal-Mart! Granted, dealers are probably not getting rich on a sled sale, but sheeze, we ARE spending THOUSANDS of dollars here! Sounds like good old fashioned customer relations and respect are in short supply at some dealers -- not good for keeping current customers happy, or for procuring future customers. -- Roy
 

·
Registered
Joined
·
86 Posts
We have been in eagle river for over 30 years. Everyone Knows not to buy from trackside. The worst run dealership[ in the country bar none. Service department seems to get their jollys over it will be 2 weeks or if you didn't buy it here it willl be 4 weeks. The only ones who still buy from them are the out of staters who have cottages and don't know any better. I to have bought one sled from them it was the worst prepped sled I ever recieved. The are definetly a gas and go dealership and make it seem like you are bothering them after the sale. This crew has no buisness being in a service oriented sales industry from the top on down.
 

·
Registered
Joined
·
3,719 Posts
Discussion Starter #6
jbscapitol,do you live in ER or just visit?This was my first and last purchace there,fortunately I knew the guy who prepped my sled,so no problems with that.Got any suggestions for a good dealership with a quality staff and service dept?
 

·
Registered
Joined
·
69 Posts
Not to throw salt in your wound - My dealer (NESCO, Governuer, NY :D ) did the updates and a 500 mile check free of charge.
 

·
Registered
Joined
·
86 Posts
My parents have retired their so I visit. Before that my grandfather owned a resort in Conover. I buy my sleds from D an D in NY and have them shipped in, keep the sleds in ER. Get my service done at mid city motor sports in west Bend.
 

·
Registered
Joined
·
3,719 Posts
Discussion Starter #10
Firefighter Thanks,I met him last winter when I rented from him,seemed like a nice guy,but his tech didn't seem the brightest?!Have you delt with him?
 

·
Registered
Joined
·
2,180 Posts
My dealer asked me to bring it when it had about 500 miles on
i brought it in with 1648 miles on ...never said a word serviced it for free!!!
 

·
Registered
Joined
·
6,125 Posts
Red f5-hay this is scott-anyways my black f5 is there right now(Falls action sports in abrams)getting check up-they did my red one also-they basically grease,check bolts,check clutches,etc.etc.etc. any ways i get along great with pat the owner and glenn the head mechanic-also t.a. motorsports near manitowoc,both great customer service and very friendly,rich and his brother own t.a. motorsports-honestly from talking to you,they do nothing more then you have already checked or done,im sure your sled is fine and no they cant use it against you as far as warranty,if you didnt bring it in.Both of mine are there-red one is leaking chaincase oil by brake rotor-jackshaft seal,im having bearings checked also-black one is there for check up and having oil pump adjusted-im running about 40-1 ratio-going to have them set up like red one about 60-1-anyways these guys treat me great -honestly if the sleds didnt have other things going wrong or needed some kind of update i probably wouldnt bring in for checkup,because you or i have probably checked most of that stuff

One more thing i got glenn calling cat about the apv cables,oil working there way up cables,cables coming off servo motor etc.-i ended up putting washers behind servo spool on each sled-my new one had less then 10 miles on it when the damn cable came off-i took the servo cover off day one-both sleds have them off now so i can keep an eye on them-also left black one stock at 34mm for cables and red one i adjusted to 38mm-didnt do a damn thing as far as performance or keeping the cables from slacking up-amsoil in one,cats apv in another-im at witts end-had to put the washers on,didnt have a choice-hopefully cat will have a fix-scott
 

·
Premium Member
Joined
·
25,555 Posts
My dealer called me and told me to bring the sled in Satuday, and he would have the updates done right then so I am set for vacation. (NESCO in Gouverneur, NY).
Any updates, the owner has personally called.
:wub: :D
 

·
Registered
Joined
·
3,719 Posts
Discussion Starter #14
Hey Scott,thanks for the reply,I hadn't had any problems with the cables until last week,around 1300 miles or so.I took them out and cleaned them thoroughly,lubed the cables and re-installed.Thought the problem was fixed until yesterday morning,it was about -10 and the sled sounded like a damn four stroke when I started it!very quiet and smooth,no two stroke rapp to it at all,probably was only one cylinder,but not sure what was the cause.One valve cable didn't return to closed after the valve cleaning cycle on start up,now I'm pissed.I let it warm up running like that for maybe a minute,then the other cyl. kicked in,weird! :wacko: poss. choke problem?The cable still hadn't retracted after 10 min of warm up,I take off and five min later the cable free's itself and I re-installed it with -out any problems for the rest of the day.Until that night after it cooled down,next time it started up,same weird running problem,only one cyl.?then it kicked in and ran fine,This cable problem is becoming frustrating,and now the running super quite almost four strokish is really strange.I guess I'm wondering if the valve being stuck open would make it run like that,or is it choke related?
 

·
Registered
Joined
·
6,125 Posts
Nope thats it-valves stuck open-and when they stick open,cables slack up and come off servo motor spool-just for shits and giggles one day when i cleaned the valves and had everthing put together,i left the cables off the servo on purpose,started the sled and pulled on the cables manually-yes very very quite-didnt have that rumble because with pulling them up at idle,now the exhaust ports are fully open and exhaust is free flowing-has nothing to do with your choke!!!!your problem is identical to mine-when very very cold they hang up until sled is nice and warm-hell it did it the next day after cleaning the valves,was
-12 out and they hung up-very very frustating,because when they hang up you lose alot of low end,and of course when the cables come off no top end-Trust me i would really like to talk to this gls guy about it-wish i had a phone number-Im also on the theory of close tolerances on valve and head or return springs not strong enough-the 02 zr500s made some changes compared to the 01s on their apv springs-tolerances-and no self clean mode at startup on 02s 500s-the 01s had self clean like firecats-Im waiting to see 04s if cat changes anything on apvs for 500s-will be interesting-i tried contacting gls on this subject on this site under talk to cat but no answer so im on my own-scott
 

·
Registered
Joined
·
3,719 Posts
Discussion Starter #16
Thanks Scott,I bet gls is a very busy man these days,give him a chance I think he'll answer,I hope so anyhow
 

·
Registered
Joined
·
745 Posts
I'll make a dealer suggestion for any of ya guys in mid WI. Smith Brothers in Mosinee. Best dealer i have ever had. Always takes care of me. My father always buys his work vehicals there, and every sled except one. If ya buy a couple sleds there they start giving ya $300-600 discounts. Plus 10% off all parts/cloths ect. They are great. Just off Highway 51 south.

Tyler
 

·
Registered
Joined
·
1,710 Posts
i also bought mine from R&R in hazelhurst. i'm impressed so far. mine is a green f7 sno pro.
 

·
Registered
Joined
·
1,123 Posts
Originally posted by bee1971@Feb 11 2003, 03:45 PM
Red f5-hay this is scott-anyways my black f5 is there right now(Falls action sports in abrams)getting check up-they did my red one also-they basically grease,check bolts,check clutches,etc.etc.etc. any ways i get along great with pat the owner and glenn the head mechanic-also t.a. motorsports near manitowoc,both great customer service and very friendly,rich and his brother own t.a. motorsports-honestly from talking to you,they do nothing more then you have already checked or done,im sure your sled is fine and no they cant use it against you as far as warranty,if you didnt bring it in.Both of mine are there-red one is leaking chaincase oil by brake rotor-jackshaft seal,im having bearings checked also-black one is there for check up and having oil pump adjusted-im running about 40-1 ratio-going to have them set up like red one about 60-1-anyways these guys treat me great -honestly if the sleds didnt have other things going wrong or needed some kind of update i probably wouldnt bring in for checkup,because you or i have probably checked most of that stuff

One more thing i got glenn calling cat about the apv cables,oil working there way up cables,cables coming off servo motor etc.-i ended up putting washers behind servo spool on each sled-my new one had less then 10 miles on it when the damn cable came off-i took the servo cover off day one-both sleds have them off now so i can keep an eye on them-also left black one stock at 34mm for cables and red one i adjusted to 38mm-didnt do a damn thing as far as performance or keeping the cables from slacking up-amsoil in one,cats apv in another-im at witts end-had to put the washers on,didnt have a choice-hopefully cat will have a fix-scott
I'll second that.....falls action in abrams and t.a. sports....both great dealers
 
1 - 19 of 19 Posts
Top