Hardcore Sledder banner
1 - 7 of 7 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter · #1 ·
i have an 06 fusion 600 and when i started this year my speedo and tach wasnt working. any ideas? i replaced the battery but that is just for the clock memory.
 

·
Registered
Joined
·
150 Posts
i have an 06 fusion 600 and when i started this year my speedo and tach wasnt working. any ideas? i replaced the battery but that is just for the clock memory.[/b]
ac dc regulator is going for shit thats your warning to replace it its under your oil bottle attachedto the tunnel not fun to replace
 

·
Registered
Joined
·
150 Posts
i have an 06 fusion 600 and when i started this year my speedo and tach wasnt working. any ideas? i replaced the battery but that is just for the clock memory.[/b]
ac dc regulator is going for shit thats your warning to replace it its under your oil bottle attachedto the tunnel not fun to replace
 

·
Premium Member
Joined
·
2,124 Posts
yep he's right gotta change the regulator i just got one in the shop today that had no gauge at all. first test the power on the red/white wire coming out of the regulator to make sure there is no power there. if you get no power then you know it is the regulator.
 

·
Registered
Joined
·
197 Posts
would this have something to do with mine also 05 fusion the dash shuts off and then comes back on like you started the sled but the sled never shuts off also the head light goes out 2 .and now when the light is on it seems like its only half as bright as it is supposed 2 b help plz
 

·
Registered
Joined
·
44 Posts
Discussion Starter · #6 ·
will the regulator have any power coming out of it? how much should it have? or will it show none? i just want to make sure i think those are around $80 and i dont want to replace it if thats not the problem. thanks
 
1 - 7 of 7 Posts
Top