Hardcore Sledder banner

1 - 14 of 14 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
I was riding around yesterday and a little red light kept coming on just under the high beam indicator. Is this the overheating light? It would turn on for no more than 2 seconds and just turn off again. It would turn on after going past half-throttle.
 

·
Premium Member
Joined
·
6,057 Posts
You machine was hot. Did you burp your cooling system? When it comes on, it makes your sled go into Fail Safe mode running it richer. What were the snow conditions like? If that happens, try and get into some loose snow so it will throw up on the heat exchanger!
 

·
Registered
Joined
·
245 Posts
UHHHTT OH. Better BURP THE PIG. Careful

well now that I think of it, that may not be a burp issue. If that was the case you'd get NO LIGHT. REASON - Cant get HIGH TEMP READING from AIR. Thats where bubble ends up, at the sensor. NEED MORE SNOW :wacko:
 

·
Registered
Joined
·
65 Posts
I had the same thing...I put a post out there. I don't think the machine was hot. The heat light is orange... right? My dealer had no idea, except maybe the battery light which would be strange since we have no battery.

Mine was on and off with no patten. machine ran great.

If you fine out waht this is please post it. I'll keep looking too.
 

·
Registered
Joined
·
236 Posts
If you own a f5 its the oil light. Its a recall and my dealer said at the 200 mile service he would change it. He wasn't concerned
 

·
Registered
Joined
·
341 Posts
Discussion Starter #6
I went over my coffee break to the dealer and picked up a jug of coolant. I'm Going to try and burp it when there is enough light outside or when I get a chance to use someones garage...
 

·
Registered
Joined
·
41 Posts
i have a coolant leak in my F5 and the dealer said they wouldnt take it back so im going to have the repair shop get it fixed hopefully.....the anti-freeze was pourin from the bottom of the tub.....it only has 18.6 miles on it <_<
 

·
Registered
Joined
·
2,705 Posts
The dealer won't fix it!!!! :angry: It's under warranty!!! They have to fix it!!! Where is this so called dealer?? :wacko:
 

·
Registered
Joined
·
41 Posts
well our warranty is through NAPA auto parts and thats a polaris dealer.........they put us on the waiting list but i just want it fixed now.......is the coolant leak a common problem?.....i think it might just be a loose hose....hopefully.....
 

·
Registered
Joined
·
56 Posts
So what are you saying --- Waiting List???? Your Polaris dealer can't sell any Polaris's or Auto Parts so they just went out and bought a F7 to broker to you so they could sell something?????? You're blowing me away. I suggest you embrace this Forum, print out the issues we are uncovering here, FIND A REAL ARCTIC CAT DEALER and have your sled properly checked out. :eek:
 

·
Registered
Joined
·
41 Posts
no..no...no.....Alaska Commercial Co. is the place we bought the snowmachine from.....but our warranty is through a polaris dealer....there they have arctic cat mechanics also......our pop. is round 5000 so they dont have many snowmachine shops around.....
 

·
Registered
Joined
·
56 Posts
Fair enough. I would still print out the issues presented here and make sure they're up to speed on what to check over on your sled... I was worried about you for a moment!!! :huh:
 

·
Registered
Joined
·
41 Posts
yeah i think thats what i'll do.....i want that snowmachine to run in excellent condition bcuz my friends want to race me already.....xcsp 500, edgex500, mxz adrenaline 600, couple of other machines....so thats what im looking forward to.....what would be a great way to break my 500 in?...any suggestions?
 
1 - 14 of 14 Posts
Top