Hardcore Sledder banner
1 - 9 of 9 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
i have a few questions i just put in a clutch kit. i drove it back and forth in the yard and it worked good. that was a few weeks ago. today i was moving the sled in the shed and the sled just stopped moving. i lifted the hood and looked at the belt ,it was loose and now when i try to move the sled the belt starts smoking and the sled goes nowhere. how do you tighten up the belt? why is it smoking ? and why is it loose? everything is tight in the clutch. does the belt come off by just pulling on the belt and forcing it off because that is how i was told to take it off and thats how i got it off when i did the clutch.
 

·
Banned
Joined
·
10,423 Posts
look under tunnel in front of skid, possible you may have picked up a rock and it jammed in between track and drivers??
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #5 ·
ya i did the clutch myself. i did everything just like the cd service manual said. i cant check my cd manual now because the cd is not working. with the sled not running i cant turn the track but it will turn if i turn the clutch hub. but with the sled up i can not turn the track by hand.
 

·
Banned
Joined
·
10,423 Posts
Originally posted by chevelle ss@Oct 15 2005, 10:10 PM
ya i did the clutch myself. i did everything just like the cd service manual said. i cant check my cd manual now because the cd is not working. with the sled not running i cant turn the track but it will turn if i turn the clutch hub. but with the sled up i can not turn the track by hand.
<div align="right">index.php?act=findpost&pid=932233
[/quote]
with weight off(track up) you can turn secondary by hand??, but with all other ways it won't turn/move at all?? this points to bindage in track/driver sprocket area pretty much
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #8 ·
Originally posted by C-NOTEPLUSf503@Oct 15 2005, 10:32 PM
with weight off(track up) you can turn secondary by hand??, but with all other ways it won't turn/move at all?? this points to bindage in track/driver sprocket area pretty much
<div align="right">index.php?act=findpost&pid=932268
[/quote]
i also installed a reverse kit. i will take the chaincase cover off and have a look
 

·
Banned
Joined
·
10,423 Posts
Originally posted by chevelle ss@Oct 15 2005, 10:36 PM
i also installed a reverse kit. i will take the chaincase cover off and have a look
<div align="right">index.php?act=findpost&pid=932275
[/quote]
:div20: now that may be a whole 'nother ball game :cn:
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top