Hardcore Sledder banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,100 Posts
Discussion Starter #1
Hi all, this is my first time on the boards but i have been on the email list for awhile ( [email protected] ) well i was out riding and BOOM my engine light started flashing.... so i stopped, looked under the hood, everything looked fine. Just passed my break in, sometimes when im starting off its BOGGY for like 5 minutes, if i down shift then accelerate it bogs and almost dies, that seems to pass after fully warmed up.

So anyway it comes back on, i stop, change the spark plugs ( a lil fat cause of break in period and oil in tank ) but overall look good...... hope back on and rip up and down the lake, BOOM engine light flickering like crazy.....

any ideas or suggestions? fuel, oil, coolant, plugs were all good.......

I am booking an appointment tomorrow but i was just wondering if anyone had this problem and know what the solution is or if its major?

thx
 

·
Registered
Joined
·
394 Posts
you got it hot, must not have been much snow on the lake!
the ckeck engine light starts flashing at 175, than stays on when it gets hotter than that. also it goes full rich at when the lights on!
READ YOUR OWNERS MANUAL!!!!!!!!!!! geez!
 

·
Registered
Joined
·
394 Posts
Yep the water you skipped on the lake in oct. cools a lot better then clear ice!!!!!!!!!!!!!!!!!!!
If the check light go's off when it cools off, that's the problem!
 

·
Registered
Joined
·
302 Posts
You may need to burp the coolant.
 

·
Premium Member
Joined
·
6,057 Posts
Yes, light will flash when hot sending sled into rich mode losing power! It then go to a constant lit state when temp reaches 190?? ( can't remember). Shut her down and trow snow onto heat exchanger! Or find some deep powder!

Burping it may work too. Try that!
 

·
Registered
Joined
·
1,100 Posts
Discussion Starter #7
There was no water in october, and since im new to the forums i am unsure of what u mean by burping it? Also it never got to the point where it just stayed on, just flashing... once it came on it never went out unless i let it idle down, goes off and then comes right back on.... im gonna do it today again and then throw snow on the running boards to see ifd light stops, either way eveyone else is riding with no problems around here.....

goes in for service on Wednesday
 

·
Registered
Joined
·
629 Posts
Originally posted by CCC Sniper@Dec 9 2002, 01:36 PM
There was no water in october, and since im new to the forums i am unsure of what u mean by burping it? Also it never got to the point where it just stayed on, just flashing... once it came on it never went out unless i let it idle down, goes off and then comes right back on.... im gonna do it today again and then throw snow on the running boards to see ifd light stops, either way eveyone else is riding with no problems around here.....

goes in for service on Wednesday
It went off when you idle due to the mag not putting out enough juice to run the system to have the light on.
 

·
Registered
Joined
·
280 Posts
You assk what Burping the cooling system ment!?
Read this: cooling system bleeding advisory

I'm from Sweden and i'm going to get my F5 next week. This web site is geting me nervous with all firecat :eek: problems.

This is my first AC i have allways hade SKI-DOO's :ph34r:
 

·
Registered
Joined
·
1,100 Posts
Discussion Starter #10
sweden dude, dont be!!!!! turns out it was lack of snow, because i went back out and dump snow on running boards and light never came back on..... i have over 300 miles on it as of today and it snowed quite a bit more. That day i was just lake running to see top end, in my opinion it aint a top end monster BUT its a out of the box monster for fun, trails, climbing, jumping.....its light and nimble and i think you would love it!!!!!

just get extra warranty and break in proper

:p
 
1 - 10 of 10 Posts
Top