Hardcore Sledder banner
1 - 20 of 76 Posts

·
Super Advanced Member
Joined
·
4,102 Posts
thats three people that have posted they blew the belt. :banghead:
 

·
Registered
Joined
·
3,175 Posts
well it seems the mountain guys arent having any probs and they got a lot more riding and punisment on there belts this year. have any of u guys addressed the shitty stock clutching issues? i have the 111 belt on mine which is supposed to be a piece of shit and its lasting.
 

·
Registered
Joined
·
2,456 Posts
this new belt you guts blew apart? The 1115? or the 1111? Nobody stated which one.

The 1111 belt I can understand it being a piece of shit. but if you are destroying the 1115, you got some other problems that need to be adressed, Something along the line of busted motor mounts, or clutching way far off!

Have you guys checked your alignment? or for busted mount bolts?
 

·
Registered
Joined
·
1,229 Posts
Gotta agree with Gettin2Old, I put almost 400 hard miles on my 1115 belt in Quebec a couple of weeks ago, in temps in the 40s....God knows how hot it got down at the clutches. The last 30 miles was a high speed limp home after the primary kept sticking 3/4's open. And the 1115 belt? Damn thing still looks like new, not a mark on her!

Something else has gotta be wrong down there!
 

·
Registered
Joined
·
161 Posts
Discussion Starter · #8 ·
It was the 1115 belt ...the free one we got. Dealer just alighned everyting and installed the torque and push arms when they installed new belt 200 miles ago...nothing wrong with sled just a poor belt the top delaminated from the bottom and blew into about 100 pieces and smashed the belly pan...glad i have slp air box because the factory one would have exploded.
 

·
Registered
Joined
·
3,175 Posts
It was the 1115 belt ...the free one we got. Dealer just alighned everyting and installed the torque and push arms when they installed new belt 200 miles ago...nothing wrong with sled just a poor belt the top delaminated from the bottom and blew into about 100 pieces and smashed the belly pan...glad i have slp air box because the factory one would have exploded.[/b]
stock clutching?
 

·
Registered
Joined
·
2,456 Posts
I qam going to guess that this belt came apart after you let off the throttle???? if this is the case, your clutching is to blame. These sleds do not need to be geared down. geraing them down is just a band-aid for the real problem.

Do not waste your money on a "performance clutch kit" just get your clutch ratio's corrected. the stock weights and primary spring are fine, the stock helix angles are too shallow. use a 420719 helix and that alone should get you at a good starting point.
 
1 - 20 of 76 Posts
Top