Hardcore Sledder banner
1 - 6 of 6 Posts

·
Registered
Joined
·
247 Posts
Discussion Starter · #1 ·
im instaling new case bearings in my 2003 zr 900 sled and the new bearings dont have an o ring on the out side of the bearing like the old ones do just on the inside , was this an update or did thay give me the wrong bearings , any help woulod be nice

thanx DAN
 

·
Registered
Joined
·
3,420 Posts
Hi Dan,
They should have given you a 1602-052 for the upper bearing and a 1602-051 for the lower chaincase bearing. I like to use the 1670-237 rubber O-rings(thicker than the stock 03 O-rings that were used originally) that go around the outer race of the bearing and get pinched by the triangular flange when tightening but the stock but AC says the stock O-rings(part# 0602-801) will be sufficient. The new bearings SHOULD NOT have a machined groove in them on the outer race like the ones you removed. The original bearings with the machined groove in the outer race were very problematic and very acceptable to breaking/cracking.

Hope this helps,
-John
 

·
Registered
Joined
·
247 Posts
Discussion Starter · #3 ·
thanx John you are a big help , the new ones did not have a groove in them , and are now installed in the sled

think snow
 

·
Registered
Joined
·
1,374 Posts
Which bearing is in the '03 ZR900's from the factory? Did they change mid-production? Were the good bearings installed on the late release? I have 2100 miles on mine should they be checked/replaced?
 
1 - 6 of 6 Posts
Top