Hardcore Sledder banner

1 - 1 of 1 Posts

·
Premium Member
Joined
·
2,693 Posts
Discussion Starter #1
My friends red Team graphics F7 just burned up. Same problems as everyone else. Said he was cruising about 70 mph and it just shut off. Restarted it and drove away and thought it was okay. I told him to check the pistons, but he said it was fine. "Felt like it ran out of gas." Took it out the Sunday night and locked it up twice more cruising at 70-75 mph. I asked him if he bled the system per the service bulletin and he didn't. He did it the same way he had always done his others. He had just finished all the updates after the first time it shut off, but I bet the damage had already been done. It was stock except for reed spacers and he bent the petal stops out. I'm assuming he checked the oil line also, but I don't know. The dealer didn't have the motor apart yet, so I couldn't see the damage. It had about 150 miles on it. It still amazes me that these problems keep happening with all the bulletins and talk there is. If you burn up your sled now and its air in the system, I don't feel bad anymore. Its getting to be plain laziness or there is an ECU problem. I wonder if the spacers or the bent stops could have an effect on it. Oh yeah, he always ran it in the ethanol mode. I can't believe the ECU can't compensate for the increase in the intake tract volume, but who knows? Mine seems fine. I'm going to keep riding it and I'm confident it will hold up to any abuse I can throw at it.
 
1 - 1 of 1 Posts
Top