Hardcore Sledder banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I hoping someone can help me out. I just recently picked up a 98' Mach Z with 2,700 miles on it. I was told the fuel gauge didn't work at times, but the problem appears to be more serious. I was checking it over the other night and the fuel gauge never worked, the temp gauge worked only for a couple a minutes, headlight switch and heated grips also don't work. I know that year had some electrical problems, but I don't know any specifics. Any help would be appreciated. Thanks!!!

Any other common problems I should be aware of?
 

·
Registered
Joined
·
42 Posts
hey,
i recently bought a 98 mach z and found out some interesting info.
There were a few recalls.....one of the harnesses that ran under the motor, which apparently would end up rubbing over time from vibration would cause shorting and loss of certain functions.
Another was one of the bearings on the pto side of the engines crank would not get oil (i believe this is the right bearing) and needed to be modified, to correct the problem. Both of these were apparently "secretly" recalled to those who had came in with these problems to the dealership, but only to the original owner. You could phone a local ski doo dealer with your vin number and find out if the recalls were done on your sled previously. If not it may be your problem. From what ive been told those were the main issues, other than that you have a decent sled.
good luck
-C
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top