Hardcore Sledder banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
I have a fresh 2021 Khaos 850 with a 2.6 155 track on the first trip out to break in the sled the engine temp would jump to 174 deg started and stopped several times could not keep the temp any lower thinking I might have a air pocket I bleed the cooling system per the operating instructions and no changes 30 deg day fresh powder scratchers down, My 2020 800 pro was running 120 deg to 135 deg in the same conditions all day. no overheat lights but only 4 deg away from hot temp lights. I took it to the dealer and they said nothing was wrong I find that hard to believe after riding 800 pros for the last 10 years ...I could not get any answers directly from polaris and got the run around...

I need to know what other 850 Pros and Khaos owners are getting for normal operating temps and if anyone has had cooling issues with the 850 less than 20 miles on my sled and heading for Island Park to ride at the end of the week any ideas Thank you
 

·
Premium Member
20 850 Assault and 21 Indy XC 650 137
Joined
·
3,160 Posts
I have a fresh 2021 Khaos 850 with a 2.6 155 track on the first trip out to break in the sled the engine temp would jump to 174 deg started and stopped several times could not keep the temp any lower thinking I might have a air pocket I bleed the cooling system per the operating instructions and no changes 30 deg day fresh powder scratchers down, My 2020 800 pro was running 120 deg to 135 deg in the same conditions all day. no overheat lights but only 4 deg away from hot temp lights. I took it to the dealer and they said nothing was wrong I find that hard to believe after riding 800 pros for the last 10 years ...I could not get any answers directly from polaris and got the run around...

I need to know what other 850 Pros and Khaos owners are getting for normal operating temps and if anyone has had cooling issues with the 850 less than 20 miles on my sled and heading for Island Park to ride at the end of the week any ideas Thank you
Yeah you shouldn't be having temp issues in fresh pow. Park the sled on a snow bank with the front elevated and try to get the coolant system to burp an air bubble out. Others have tipped the sled on its side to get the air out.
 

·
Registered
19SKS850,17Assault815BCX.13BCX,to96XCR6;-} Six Star:Lodge At HWL
Joined
·
213 Posts
Dont temp light and limp mode start above 200 degrees?
 

·
Registered
Joined
·
84 Posts
Different sled but just took my 21 850 assault 2” track for a maiden voyage in a foot of snow and I could hardly believe it ran right at 100 sometimes 102 degrees
 
1 - 5 of 5 Posts
Top