Hardcore Sledder banner

1 - 18 of 18 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey all,

Just wondering if anybody has been having a hard time with their IACT.

I have had 2 sleds with the IACT and both have shown codes.

Sled #1: C1525 and C1526
Sled #2: C1523 with 40 miles

Spoke to all dealerships around me and they have all told me that they have not had any issues at all. Also told me that "C" codes are not arctic cat, even though I'm pretty sure that 2019 Thundercat is an Arctic Cat.

If you've had these codes, please let me know if/how it was fixed.
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter #4
No symptoms, code and it defaults to super stiff. Went riding last night and trails were tabletop. Would have loved to have been able to flick it to soft and rip. Just not the same on stiff...

Pretty frustrated that all dealers say they haven't had issues but I have had 2 sleds in 2 months and they both have had issues..
 

·
Registered
Joined
·
2,955 Posts
Maybe try a get in contact with area cat factory rep or cat them self's in Thief River.
 

·
Registered
Joined
·
86 Posts
I have the 2019 ZR 8000 Limited with iAct and had a problem. The right shock would not adjust to the Firm position. Could not tell if all shocks actually adjusted between Soft or Medium. I did not get any codes on the display. Took to dealer. They checked it out and found codes c1523, c1524, c1525, & c1526. They called Cat. The tech, at Cat, told them to replace the shock. Appears to be working now. Again, I did not get any codes on the display like you have. The dealer found the codes. Not sure if this helps or not. Do your shocks actually change? When I first got my sled I could not tell much of any difference in the settings while riding. While stationary I found out mine was not working by changing the settings and rocking the sled back and forth after each setting. I could tell that the rear shock was changing and possibly the left shock too but the right shock would still bounce on the Firm setting. After the dealer replaced the right shock, and rocking the sled on the Firm setting, the sled is rock solid now all around.

I have no idea what these codes mean but they have something to do with the shocks not changing even though the display says they are. I do not know why my display did not show these codes and yours does. The dealer must have found them by hooking it up to the computer.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
I have talked to a few different dealerships and they have all told me that I need to tae the sled in.

I will be bringing it in in the net week to get looked at. Just frustrating that I will likely have to be without my sled for over a week. I typically go 1-2 times per week, and this winter has been FANTASTIC!!

If anyone else has had issues, please share for information.
 

·
Premium Member
Joined
·
2,670 Posts
Check your connections just to see if there is a loose wire in one of the plugs(one pulled out enough to have poor connection)and also check to see if a wire is rubbed through. Rear skid has an outer and an inner wire holder by chaincase. I put my sled together and made sure everything was clear from wires rubbing anything and that they didn’t have tension on wires.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
IMO, I think everyone should of seen this coming. This electric remote adjust system is is not conducive to the environment in which these things are used. Problems are only going to increase as time in service goes by.
Thank you very much for your helpful and constructive advice.
 

·
Registered
Joined
·
86 Posts
Crushed It:

When you get your sled fixed can you report back here what was found out? Curious to know because we had the same codes but mine was fixed by replacing a shock. As stated before I did not get the codes on the dash. Dealer got them. Wondering if there may be something else. Maybe the module? Hope you get it fixed quick. My dealer was great at getting it fixed right away. Thanks.
 

·
Registered
Joined
·
8,460 Posts
I got the C1524 code today and it was flipping' cold out. Waiting for the sled to thaw outing then we will see if it a loose connection or frosty conditions related. Just checked sled and I have a 1524 and 1523 codes.
 

·
Registered
Joined
·
18 Posts
I had 1525 &1526 codes at the end of last season, same code but left side vs right side. As mentioned above it was the module. Luckily it was replaced under warranty so I saved the $200 or so for the module. Module sits just behind the intercooler, two 8 or 10mm bolts hold it in. Very easy to replace.
 
1 - 18 of 18 Posts
Top