Hardcore Sledder banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Bought a 2019 arctic cat 8000 high country ctec 2 with 254 miles on it.I put 250 miles on it so far and fouled 4 plugs all on the clutch side and it is happening while warming up. I'm hearing that this is the side that is losing the top end just wondering if its getting to much oil because the plugs that foul are black with oil when i take it out , didn't no if they changed the oil mapping to compensate and give that cylinder extra oil and this is y I'm fouling plugs any help would be appreciated thanks.
 

·
Premium Member
Joined
·
20,462 Posts
Let it us know when you figure it out. I’ve never heard of a fouling issue. I’d think that dealer software will be needed to check oil flow, injectors, timing etc. It could be getting fuel fouled too. Piston looks good and exhaust valves work proper? (Runs strong and at 8k ish rpm)
 

·
Registered
Joined
·
16 Posts
Had a 018 HC, selling my 019HC & have a 021 Riot. Never fouled 1 plug. I even heat sink the motors 3 times. After I get the sleds. Just and idea . Take the hood off & look in the air box. See if there's a puddle of oil in front of the throttle bodies. I know after I heat sink my sleds. There is blow back oil in there. That I usually wipe out. But I also run a Y-pipe and a can on my sleds. Good Luck ! Also the Wrench code didn't come on the speedo ? Did it ?
 

·
Premium Member
Joined
·
20,462 Posts
I haven’t fouled a plug in the last 21 years. Have three c-tecs, tuned, exra tuned,stock, they will idle all day. I think something is wrong with this one
 
1 - 6 of 6 Posts
Top