Hardcore Sledder banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey there,


Had some troubles getting my E-start to engage last season. Getting around to looking at it now. I had replaced the battery last season but still experienced issues.
So I ordered up and replaced both the flex shaft and the ASM-pinion/pinion bracket (the bendix). Reassembled and still running into the same issue where the bendix fails to fully engage and crashes into the primary clutch ring gear then just spins.



It is possible the issue is still battery. I've had a charger on it and its reading full. I don't have a load tester so I cannot prove out that the battery isn't a dud but if I leave the charger on the battery and slide it to 25 Amp I still find the bendix won't engage.


Another new battery feels like the next step to me, but beyond that I don't know what else could be causing the issue? Is the starter itself shot?
 

·
Premium Member
Joined
·
16,062 Posts
Hey there,


Had some troubles getting my E-start to engage last season. Getting around to looking at it now. I had replaced the battery last season but still experienced issues.
So I ordered up and replaced both the flex shaft and the ASM-pinion/pinion bracket (the bendix). Reassembled and still running into the same issue where the bendix fails to fully engage and crashes into the primary clutch ring gear then just spins.




It is possible the issue is still battery. I've had a charger on it and its reading full. I don't have a load tester so I cannot prove out that the battery isn't a dud but if I leave the charger on the battery and slide it to 25 Amp I still find the bendix won't engage.


Another new battery feels like the next step to me, but beyond that I don't know what else could be causing the issue? Is the starter itself shot?
Attach a second battery with jumper cables to old battery. If still doesn't work, starter or battery cables may be bad.
 
1 - 2 of 2 Posts
Top