Hardcore Sledder banner
1 - 9 of 9 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Was up in Minocqua, WI. over the weekend. Did some racing on the lakes up there. Was doing 100mph across the lake and my sled just shut down. Almost like i burnt it down or something. Went to start it, nothing. Tried to turn the secondary and couldn't get it to turn, almost like it was locked up. Taking it to the dealer Wen. A real bummer. I don't have a clue right now on what went wrong.
 

·
Registered
Joined
·
280 Posts
I think stuff like this is way more and more people are ditching sleds. Yes this type of stuff is covered under warranty but it does ruin your vacation. I have had many people I know have burn downs, coolant leaks and weird crap happen on sleds with less than 2000 miles and less than 4 years old. Many of them only ride maybe 500 to 800 miles a year. A $1000 repair bill takes the fun out of sledding.

Solution???? Maybe the fourstroke models are more reliable, even when new?
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
10-4. You want to know the worst thing about the whole deal. My buddy dragged me off the lake with his Polaris. Hope there wasn't no pics of that taken.
 

·
Registered
Joined
·
497 Posts
I think stuff like this is way more and more people are ditching sleds. Yes this type of stuff is covered under warranty but it does ruin your vacation. I have had many people I know have burn downs, coolant leaks and weird crap happen on sleds with less than 2000 miles and less than 4 years old. Many of them only ride maybe 500 to 800 miles a year. A $1000 repair bill takes the fun out of sledding.

Solution???? Maybe the fourstroke models are more reliable, even when new?[/b]
Fuse on the SDI system blown? Simple fix if this is the case.
 

·
Registered
Joined
·
5,242 Posts
10-4. You want to know the worst thing about the whole deal. My buddy dragged me off the lake with his Polaris. Hope there wasn't no pics of that taken.[/b]


Usually its the cats getting towed in my neck of the woods. LOL
 

·
Registered
Joined
·
205 Posts
Was up in Minocqua, WI. over the weekend. Did some racing on the lakes up there. Was doing 100mph across the lake and my sled just shut down. Almost like i burnt it down or something. Went to start it, nothing. Tried to turn the secondary and couldn't get it to turn, almost like it was locked up. Taking it to the dealer Wen. A real bummer. I don't have a clue right now on what went wrong.[/b]
That just doesn't make a whole lot of sense. If the secondary wouldn't turn, something is locked up in the drivetrain, but the engine should still run. Do you mean the primary wouldn't turn. That would make more sense.
 

·
Registered
Joined
·
89 Posts
That just doesn't make a whole lot of sense. If the secondary wouldn't turn, something is locked up in the drivetrain, but the engine should still run. Do you mean the primary wouldn't turn. That would make more sense.[/b]

O and by the way NEVER hold a brand new sled wide open accross the lake
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #9 ·
That just doesn't make a whole lot of sense. If the secondary wouldn't turn, something is locked up in the drivetrain, but the engine should still run. Do you mean the primary wouldn't turn. That would make more sense.[/b]
Dealer said blown crank. Warranty work, big time.
 
1 - 9 of 9 Posts
Top