Hardcore Sledder banner

21 - 35 of 35 Posts

·
Registered
Joined
·
254 Posts
Good info guys.I had a 900 fusion for years with no problems but every time I bumped into people on the trail they would tell me how much of a piece of shit it was.They never rode or had one but we’re experts anyway.I would smoke them on the trails and lakes.Nice to get good feed back without the sarcastic remarks.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #28
Do you remember if it was the harness on the stator side othe the sled harness?
the whole stator assembly was replaced and it's been fine since. It's worth the money bc if it hasn't been changed it more than likely will fail when you don't want it to.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #30
Ok I replaced the stator. No change
the only other explantion that the dealer that ran a check on mine was it could be fuel injectors. (This was before the stator was changed which was the issue on mine). That's the only other info I have regarding this issue.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #33 (Edited)
Alright thank you. I’️ll look into that
Did you figure out whats wrong with your Fusion?
Yes it was the stator. Had a broken wire inside. New stator and it's ran fine since. I unfortunately sold it before I found out that all I had to do was replace this $100 part lol. But I'm friends with the guy who bought it and he informed me that's all it was. If your having the same issue and a new stator doesn't fix it the dealer said it could be injectors.
 

·
Registered
Joined
·
88 Posts
Yes it was the stator. Had a broken wire inside. New stator and it's ran fine since. I unfortunately sold it before I found out that all I had to do was replace this $100 part lol. But I'm friends with the guy who bought it and he informed me that's all it was. If your having the same issue and a new stator doesn't fix it the dealer said it could be injectors.
I looked up a stator on Babbits and its $365, where you find it for $100 ?
 
21 - 35 of 35 Posts
Top