Hardcore Sledder banner
1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
im having really bad luck with this sled. Im getting really discouraged about this sled

i had the clutch rebuild twice, drive shaft bearings replaced, the rear suspension rebuilt.

just did the secondary tonight, after installing it started it up let it warm up, drove it for two minutes and all the electrical just stopped working


all these problems occured within the first 200 km's ive put on this sled

whats next?

any ideas on what my new problem could be?
 

·
Registered
Joined
·
468 Posts
why did the clutches need rebuilding twice?

can you perform some simple electrical tests and follow a wire diagram schematic? if so, the problem shouldnt be hard to diagnose.

check over all the plugs that come out of the stator and follow them througout the harness. if everything visually checks out alright and nothing is shorted out, it could be a faulty stator.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #4 ·
yeah im kinda thinkn that, i might go with a f6 or f7, or a prox 600/700

if anyone wants to trade !

other than that im gonna fix it and keep on fixin it

guy i bought it from said it was mint as i got lookin at it i started finding little things wrong with it

clutches were messed up rebuild once and didn't last (i think it was mechanic error) second time was done properly and still working good
 

·
Registered
Joined
·
17,180 Posts
Could be a faulty regulator, unplug it with the sled running at idle to see if anything happens (Dont run too high rpm without the regulator attached, or you may risk frying bulbs etc. )
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
thanks man thats the ticket, unpluged it and fired it up everythings a go

off to buy a voltage regulator tomorrow, it was idling alot smoother too
 

·
Registered
Joined
·
234 Posts
id junk the dam thing and get a new one. i find it very discouraging when stuff keeps happening and winter only lasts so long you dont have a ton of time to ride. my advice is to start shopping.
 

·
Registered
Joined
·
215 Posts
Ouch i had same abd luck before bought a 93 indy 500 efi for 500 dollars had to drop in new (used) engine than new clutch and alot of repairing and mainance after the 3 years were done with it i put a total of i think 1700 dollars extra into it
 
1 - 10 of 10 Posts
Top