Hardcore Sledder banner
1 - 7 of 7 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
ive got a sno pro with the d&d 640 kit on it for some reason i can not get the thing to rev higher the 7000 at 1st glance it looked like the clutch was froze up the weights were not moveing so i got new ones for d&d it got some of its snap back but the thing just revs but to 7000 and will not go ne further if u put the track in the air it sits at 7000 for a sec or 2 then it will rev out ive tryed opening the power valves all the way and still nothing im not ture sure what could be eating this thing any suggestions thanks Jim
 

·
Registered
Joined
·
21,067 Posts
Will rev out under a load? A lot of sleds will not hit top RPM spinning on the track on the stand. They need to be loaded down to hit the top end RPM.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #4 ·
it will not rev out with a lod on it when u have it on a stand it will rev to around 7k thenafter a sec it kicks up to 8-9k ive put new rings in it and power valve controllers and new clutch weights so im lost
 

·
Banned
Joined
·
1,883 Posts
Could be a clutching or electrical problem.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #6 ·
ive been sugessted that it could also be the temp sending unit on the pipe what do u all think of that
 

·
Registered
Joined
·
2,683 Posts
Check your CD and that you have the right belt on for your clutch and that your motor is tight and not moving around
 
1 - 7 of 7 Posts
Top