Hardcore Sledder banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 1997 ext 600. the shaft is not sticking out far enough to spin the oil pump. I think I the waterpump impeller is pushed to far forward(spring behind it). I replaced the impeller and the problem is still there. It looks like the waterpump cover is extremely worn and the impeller is going to far forward. Is the impeller supposed to wear into the cover??? Mine is! PLease help. PLEASE
thanks
Ray
 

·
Registered
Joined
·
35 Posts
Was the gear properly aligned with the slot of the oil injection shaft? (making sure the slot in the oil injection pump is correctly aligned with the oil injection pump drive gear)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Yes. Even if it wasn't, wouldn't you think it would have spun into place after a seconed. But yeh I am pretty sure that was all ok. thanks
Ray
 

·
Banned
Joined
·
10,423 Posts
FWIW,, sounds like the case has gotten worn or corroded away where the oil pump shaft ''bottoms'' inside and is letting the spring ''push'' the impeller and shaft forward too far, BETTER get this checked immediately!!

EDIT: the one i saw before was from someone ''grinding'' the flat stopper surface on the shaft down in diameter, so that they could install shaft from outside i believe, this allowed it to eat into the lower case(probably forgot to install it before assembling case halves) :frech32: :dunno:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Ahhh you think where the shaft rides inside the case on the water pump side it is worn into the case. I guess I would need to split the case and look at where it rides on the case on inside. I wonder if that is the case if I could put a shim in there. thanks
Ray
 

·
Banned
Joined
·
10,423 Posts
:dunno: possibly depending on the amt of damage if this proves to be the(no pun intended)case :smilielol: ,,, i'd probably look for another case/shaft combo myself,,
 
1 - 7 of 7 Posts
Top