Hardcore Sledder banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
we have a 1995 polaris xlt 600 triple.... it starts and idles fine but, it wont rev past 4500 rpms? if you get on the sled and try to take off it just bogs down and wants to die?...anyone know what the problem could be? any help will be greatly appreciated!

thanks
 

·
Registered
Joined
·
264 Posts
After you've confirmed it has good compression on all cylinders, you might have to go in there and check the carbs for clogged jets and such, prob bad gas from sitting.
That's where I'd start, it's usually dirty carbs. :div20:

Plus if you're trying to run it in warm weather, the needle jet setting will be a little rich if it's still the stock jetting.
 

·
Registered
Joined
·
671 Posts
Might check to see if a cable came loose from a carb slider. Been down that road myself.
 

·
Registered
Joined
·
67 Posts
we fought that on one of our xlt's, after rebuilding the carbs, we ended up replacing the secondary clutch, worked fine after that.
 

·
Premium Member
MY21 650 SBA 146, ES, ICE Storm 1.5
Joined
·
6,145 Posts
Originally posted by lephelps78@Sep 22 2005, 12:00 PM
we have a 1995 polaris xlt 600 triple.... it starts and idles fine but,  it wont rev past 4500 rpms?  if you get on the sled and try to take off it just bogs down and wants to die?...anyone know what the problem could be? any help will be greatly appreciated!

thanks
<div align="right">index.php?act=findpost&pid=886967
[/quote]
Dirty carbs, jetting, or cables could do it, for sure,

Also compression.

If the sled has been in storage and the exhaust sounds muffled, check for mouse nests in the muffler or exhaust pipe.
 

·
Registered
Joined
·
537 Posts
change the plugs, clean carbs.
the one i had loved plugs... fouled the all the time. just don't let in idle to long.
 

·
Registered
Joined
·
823 Posts
yup...id say carbs or clutch. since your not hvaing trouble getting it started, i don't think compression is the issue...but could be i guess....

Champaign, huh? I thought I was the furthest south on here!! :) Where do you ride?
 

·
Registered
Joined
·
405 Posts
I agree with a bunch all up above.


- carbs (starving for fuel, dirty carbs, broken/cracked/pinch fuel line)
- check the fuel pump (seem to me, somebody left that therory out) tsk tsk tsk :beerchug:

- compression (weak compression/fouled plugs)
- shorten wire(s) someplace.

Anyone?
WL
 
1 - 10 of 10 Posts
Top