Hardcore Sledder banner
1 - 14 of 14 Posts

·
Registered
2016 Ski doo Mxz Blizzard 800r etec, 1997 Ski doo Formula z 583 mod
Joined
·
8 Posts
Discussion Starter · #1 ·
I have a 2016 ski doo mxz blizzard 800r etec that is giving me issues with starting after an engine rebuild. It has great spark, 140 compression and is getting fuel through the injectors. I also changed the plugs several times. It fires when i crank it but doesnt stay running. it backfires when you hold the throttle. i am needing suggestions from sledding veterans that have experience.
 

·
Super Moderator
2016 1200 Renegade X
Joined
·
174 Posts
I don’t know much about the 800, but is there a particular order to the injectors?


Sent from my iPhone using Tapajunk Pro
 

·
Registered
2016 Ski doo Mxz Blizzard 800r etec, 1997 Ski doo Formula z 583 mod
Joined
·
8 Posts
Discussion Starter · #4 ·
Yes the injectors have an order on the mag and pto side. they are in the right order.
 

·
Registered
Joined
·
204 Posts
Check the wiring going to the tps and the tps itself if you can. Might have to hook it to buds if you can’t keep it running long enough to get a code to flash on it to see if there is one.
was the crank new/rebuilt too?
 

·
Registered
2016 Ski doo Mxz Blizzard 800r etec, 1997 Ski doo Formula z 583 mod
Joined
·
8 Posts
Discussion Starter · #6 ·
No, i bought crank with 1000 miles and used it, i checked the the bearings out too. It doesnt run long enough for lights to come on the screen.
 

·
Registered
2016 Ski doo Mxz Blizzard 800r etec, 1997 Ski doo Formula z 583 mod
Joined
·
8 Posts
Discussion Starter · #7 ·
Can you buy the buds software?
 

·
Registered
Joined
·
204 Posts
Can you buy the buds software?
You can buy a knock off but not worth the time/money for the one time use. It’s a couple of grand to get it set up and working as it should. Not worth the investment in this case
Dealer for a reset in my opinion of the tps. If that’s not the case …. Check the crank for runout at the head ..Low mile used isn’t always good for a part out reason
 

·
Registered
2016 Ski doo Mxz Blizzard 800r etec, 1997 Ski doo Formula z 583 mod
Joined
·
8 Posts
Discussion Starter · #12 ·
I got a good crank, i checked the psi on the ecm which is very good. I tryed changing the injector electrical connections, and that didn't help. Tryed switching plug wires which resulted in a very loud backfire.:rolleyes: I' ll have to get it checked out on buds. Thanks guys.
 

·
Registered
Joined
·
5,087 Posts
How did the engine burn down in the first place?

800 etecs have burnt down in the past due to a bad fuel injector.

Also did you prime the oil system? Normally this is done by the dealership using the buds software
 
1 - 14 of 14 Posts
Top