Hardcore Sledder banner
1 - 17 of 17 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter · #1 ·
Riding the other night she blew up. took it to the dealer gonna tear it apart monday. First thing will have me up in a week he says by next weekend./ Dont have a clue why she did it. this sucks...
 

·
Registered
Joined
·
59 Posts
Riding the other night she blew up. took it to the dealer gonna tear it apart monday. First thing will have me up in a week he says by next weekend./ Dont have a clue why she did it. this sucks...[/b]
Did you have the reflash done?
 

·
Vendor
Joined
·
4,743 Posts
My buds blew up twice. Once before the reflash and once after. Now his is in again. It appears his stator went out. I just got mine back. It needed a new stator and voltage regulator. Mine is a Carbed 600. What is wrong with these new Polaris sleds breaking down all the time?
 

·
Registered
Joined
·
133 Posts
My buds blew up twice. Once before the reflash and once after. Now his is in again. It appears his stator went out. I just got mine back. It needed a new stator and voltage regulator. Mine is a Carbed 600. What is wrong with these new Polaris sleds breaking down all the time?[/b]
I got 1700 miles on mine no problems whats so ever,great sled ,sorry to hear your having so much trouble.
Maybe yours was built on a Monday...lol! :polaris_rules:
 

·
Registered
Joined
·
255 Posts
Discussion Starter · #10 ·
it was after the reflash, just installed a new 1/25 ripsaw, sled was going awesome all night, just holding it across a long field and it shut down, so then i waited a bit then poured some oil the cylinders and then drove it 200 yards to the road and my bro came and picked me up.....
 

·
Registered
Joined
·
2,170 Posts
My buds blew up twice. Once before the reflash and once after. Now his is in again. It appears his stator went out. I just got mine back. It needed a new stator and voltage regulator. Mine is a Carbed 600. What is wrong with these new Polaris sleds breaking down all the time?[/b]
Randy,
Your new 08? Not sure why all these stators are failing...they are the same part as the older 600VES motors, and those never went bad. The voltage regulator was also updated last year, so I'm disappointed to hear that they are still having issues with that. Anybody check to see if they are now made in China? That would explain it.
 

·
Registered
Joined
·
3,896 Posts
I think I'm going to have an old, faulty 600 stator rewound over the summer by a reputable shop. That'll at least give me some added peace of mind having a spare..
 

·
Registered
Joined
·
255 Posts
Discussion Starter · #13 ·
Just calle dthe dealer. Lost a base gasket. leaned out the pto side. All the parts are ordered and shewill be running by this weekend said i will be able to pick it up on friday by noon. I am glad i put a 1.25 ripsaw i know that. Told the mechanics she was goin the base gasket they told me it wasnt. O well she is warrantied.
 

·
Banned
Joined
·
8,931 Posts
There was a tip in one of the snowmobile mags the other year about stators going in Polaris's. If I remember correctly it was in the later Edge chassis ?

Anyhow, they mentioned they used cheap windings and to send it to 'The Stator Corp' in MA.

Reason why I remember this article is because of it's proximity. MA and aftermarket snowmobile parts usually don't come up in same sentence. LOL.
 

·
Vendor
Joined
·
4,743 Posts
Randy,
Your new 08? Not sure why all these stators are failing...they are the same part as the older 600VES motors, and those never went bad. The voltage regulator was also updated last year, so I'm disappointed to hear that they are still having issues with that. Anybody check to see if they are now made in China? That would explain it.[/b]

Mine ran good this weekend except a few times when it cut out or missed. I had a hard lock turn to the right where it kept dieing. I am sure it is a short in the harness.

My buds CFI ended up being a short in the wiring harness and not the stator. So far the dealer replaced a failed voltage regulator and a bad stator, no I told them to replace the wiring harness which may have lead to the other failed components.
 

·
Banned
Joined
·
8,931 Posts
There was a tip in one of the snowmobile mags the other year about stators going in Polaris's. If I remember correctly it was in the later Edge chassis ?

Anyhow, they mentioned they used cheap windings and to send it to 'The Stator Corp' in MA.
Reason why I remember this article is because of it's proximity. MA and aftermarket snowmobile parts usually don't come up in same sentence. LOL.[/b]
Found their info. 1st company in "Parts and Accessories" section.
Look at bottom of page 1 and top of page 2.
 
1 - 17 of 17 Posts
Top