Hardcore Sledder banner

1 - 20 of 21 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter · #1 ·
I did a search and did not find a positive answer I know the part # is different but has any installed a 05 speedo part # 0620-292 in a 03 f7?
 

·
Registered
Joined
·
3,047 Posts
From what i've herd on the boards is that the 05 speedo is not compatible with the 03 sled, or the other way around. The 05 only picks up a signal like every 3rd shaft revelation as opposed to every revelation...IDK
 

·
Premium Member
Joined
·
15,688 Posts
Try it and see. I don't think they do though.
 

·
Registered
Joined
·
6,171 Posts
Well the 2004 speedo works in the 2003 sleds

2004 speedo part # 0620 - 288 When you click on that # it has been updated or superseded to part # 0620 - 292 for 2004 same as the 2005 sleds

I should take the 05 speedo out of my sled and put it in my wifes 03 and see if it blows up - Maybe in the next few weeks as i am interested in a new speedo for her sled as she wants to keep the sled for as long as i want to keep her :flush:
 

·
Doesn't play well with other
Joined
·
5,450 Posts
I know for an absolute fact that some/if not all 05 speedo's will not work in 02-03 F2 chassis's.

Buddy of mine bought one and the fast it would register was about 35 mph. The tach worked fine but no matter if the speedo was on digital or analog the fastest it would register was about 35mph.

Sorry if thats not what you wanna hear.
Flash and Flare

PS. Buyer beware of all the new style speedo's on eBay for sale that say they "will" work.
 

·
Registered
Joined
·
3,279 Posts
03's have 10 tooth drivers. i think you might need 9 tooth drivers and a new speed sensor i'm not sure. i already put 9 tooth drivers in my 03 and bought a 04 speedometer when they first came out and i've had no problems
 

·
Doesn't play well with other
Joined
·
5,450 Posts
Originally posted by Arcticfreak@Sep 18 2005, 10:40 AM
Sorry Guys but the 05' speedos DO work in the 03's

:beerchug:
<div align="right">index.php?act=findpost&pid=880109
[/quote]

You are right, they will work. Correctly now thats a diff story, maybe list your serial number so we know what one you had cause the one my buddy had didn't display the correct speed. :frech32:
 

·
Registered
Joined
·
1,656 Posts
An 04 speed will work fine. The difference in shaft size is changed in the magnet placement in the shaft itself. I found this out for a fact as I put an 04 speedo in my 03 and it worked fine with my 10tooth drivers tell I put 9s on my 10 shaft not thinking of that part.

On the other hand the pickup on the 05s will be different unless you get a speedo out of a 05 with the reverse and regualar chaincase system. I don't have any experience but i'm assuming there is a difference in how the signal is sent if they stop at a certain speed. By the looks of the parts diagram it picks the speed up off the input shaft on the direct drive before the reduction to the lower drive shaft were on normal chaincase sleds it picked it up off the actual driver shaft.
 

·
Registered
Joined
·
1,952 Posts
i have an 05 speedo on my 03, it seems to work but the speed issue i cannot say since i haven't ridden anywhere. the 03's and 05's have the same 10 tooth drivers. the 04 speedo updates to the new 05 speedo as far as part numbers which tells me it should work. also the wiring into the back of the speedo it what determines whether it has 9tooth drivers or 10 tooth. pin number 12 on speedometer.
 

·
Registered
Joined
·
689 Posts
f7snoproo1 is correct, the wiring is what determines how the spedo reads 9t or 10t drivers. I have an 05 speedo on my 03 but i also have 9t drivers. The 04 has a extra wire going into the back of the spedo, so i had to get the wiring harness from a 04 that goes from the ecu to the spedo since my 03 harness didn't have it.
 

·
Premium Member
Joined
·
3,173 Posts
When we did the group buy from ODS last season, did he ship 04 or 05 speedo's??? Whatever he shipped me worked great all last season in my 03 and was nice and bright too! Thanks again Dan!! :div20:
 

·
Registered
Joined
·
706 Posts
I have two white face speedo here. One is 0620-288 and the other is 0620-292 and I also have a stock black 03 speedo. I did a test with all three with a 03 f7 on a trailer and at 4000 RPM and 5000 RPM the speeds all read the same. This is around 65 MPH at approx. 5200 RPM. So I guess I answered the question the 04 and 05 speedos work, well at least the two I have..............Brian
 

·
Registered
Joined
·
6,171 Posts
Originally posted by mouse trap@Sep 25 2005, 04:00 PM
I have two white face speedo here. One is 0620-288 and the other is 0620-292 and I also have a stock black 03 speedo. I did a test with all three with a 03 f7 on a trailer and at 4000 RPM and 5000 RPM the speeds all read the same. This is around 65 MPH at approx. 5200 RPM. So I guess I answered the question the 04 and 05 speedos work, well at least the two I have..............Brian
<div align="right">index.php?act=findpost&pid=891916
[/quote]

Nothing like an actual test to get the answers your looking for :beerchug:
I think this question has been answered , sealed and put to rest :div20:
 

·
Doesn't play well with other
Joined
·
5,450 Posts
Originally posted by 128JetSnake@Sep 26 2005, 12:54 AM
Well wait a minute, there's one more thing, oh never mind.
<div align="right">index.php?act=findpost&pid=892715
[/quote]

Ya, there is only 1 thing.................what was up with my buddies speedo ?
Flash and Flare
 

·
Registered
Joined
·
2,849 Posts
Originally posted by Flash and Flare@Sep 26 2005, 01:35 AM
Ya, there is only 1 thing.................what was up with my buddies speedo ?     
Flash and Flare
<div align="right">index.php?act=findpost&pid=892737
[/quote]

So, how'd your buddy look in a speedo?


Forgive me, I'm at work and I'm bord. Don't worry, even my supervisor knows I'm on HCS, just not much to do.
 
1 - 20 of 21 Posts
Top