Hardcore Sledder banner
1 - 15 of 15 Posts

·
Registered
Joined
·
1,672 Posts
Discussion Starter · #1 ·
I bought a brand new 05 F7 EFI at the tail end of last season. I put 362 miles on it in one trip to Maine. The sled got 8 mpg, that seems pretty poor to me. Also, it used 5 quarts of oil in those 362 miles, that also seems high. Can the dealer correct this or am I doomed? :dunno:
 

·
Registered
Joined
·
10,641 Posts
take it back to the dealer. that mileage is bad and the oil is horrible! i use less than 2 qts in that amount of miles!
 

·
Registered
Joined
·
1,686 Posts
Originally posted by GearHd6@Sep 29 2005, 04:53 PM
I bought a brand new 05 F7 EFI at the tail end of last season. I put 362 miles on it in one trip to Maine. The sled got 8 mpg, that seems pretty poor to me. Also, it used 5 quarts of oil in those 362 miles, that also seems high. Can the dealer correct this or am I doomed? :dunno:
<div align="right">index.php?act=findpost&pid=899725
[/quote]
oil can be adjusted but your fuel consumption can not. i have found if you hold the throttle some what steady rather than abrupt on/off mileage increases. i have gotten as bad as 11 mpg on a rx1.
some will say it is a problem with your efi, but if it doesn't foul plugs efi is probably ok. also if there are no codes being sent by the computer efi is probably ok.
 

·
Registered
Joined
·
1,817 Posts
I have an 05 f6 efi the same way i used a gallon of oil just to 286 miles and gas isn't all that bad but my plugs are allways wet and black so i am off to the dealer with mine again had it there before with this problem they said they adjusted my oil pump but it still very hard on oil. and they replaced the ecu saying it was a gas problem but all the same with this ecu so i hope to have it fixed right for this comming season.
 

·
Registered
Joined
·
968 Posts
I bought my 05 F7 feb 19th, and put on 1300 miles, I averaged 8.8 mpg for most of that, and my oil consumption is terrible! I hae turned my oil pump down 7 turns on the rod, but I have yet to check fuel pressure to see if that is causing the low mpg. I do know that my sled takes 3 pulls minimum to start where as most take only 2,and my plugs are wet fouled looking all the time. I thnk a fuel pressure check is in order for you and me.
 

·
Registered
Joined
·
580 Posts
Originally posted by bgbytoys@Sep 29 2005, 06:05 PM
oil can be adjusted but your fuel consumption can not. i have found if you hold the throttle some what steady rather than abrupt on/off mileage increases. i have gotten as bad as 11 mpg on a rx1.
some will say it is a problem with your efi, but if it doesn't foul plugs efi is probably ok. also if there are no codes being sent by the computer efi is probably ok.
<div align="right">index.php?act=findpost&pid=899884
[/quote]
I disagree big time,my 2004 F 7 efi was hard on gas like you,but was running fine,told my dealer and he check my pistons and found found that the piston and cylinder was scorched,they change it and boy what a difference it made,more power and big diff on the gas millage.
 

·
Registered
Joined
·
1,041 Posts
interesting i have gotten 12 mpg and i had to figure oil consumption took a while but got it worked out. used to use oil like it was set up in iraq but now under control have to check pistons and cylinders

Jay
 

·
Registered
Joined
·
1,817 Posts
well my 05 f6 has 320 miles on it and checked my compression in my cyclenders and i am running around 125 is that normal?
 
1 - 15 of 15 Posts
Top