Hardcore Sledder banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. IQ chassis
    I have a 2009 dragon 800. About 20 miles into my ride on Sunday my dash went out, and seldom came back on during high revs. The riders in front of me said they noticed my head lights would dim then go completely dead. Shortly their after the sled would just quit, shut down....... but on first...
  2. IQ chassis
    I’m riding a 2007 switchback 600. It’s been a great sled for me but last year I had broke a belt trail riding with a buddy. We got the spare on and all was fine but now the MFD cuts out. It’s fine if I’m going slow or slowly throttle up but if I go over 1/2 throttle it’ll cut out. As soon as I...
  3. IQ chassis
    my dragon 600 blew 2 ecu's within a week of each other it went like this for the second one. turn it on, runs for a little bit then spits a bunch of smoke from the electrical panel and dies. when i take the ecu off there's a burn mark on the bottom of the ecu and a small hole in it I've...
  4. General Snowmobile Forum
    Guys I just picked up a 99 XCF with 826 miles on it. Unfortunately it was neglected. I found it after it sat outside on a trailer for two years...Gas looked like Hi-C. I drained the gas and cleaned the carbs twice now. The sled starts on the first or second pull and runs pretty well. I think I...
  5. IQ chassis
    Hello all this is my first post here. I just obtained an 07 RMK for a pretty decent price. When I picked it up it ran great with awesome compression numbers and such. Recently though I installed some new spark plugs then went to start it up again. It proceeded to die after about 10 seconds of...
1-5 of 5 Results
Top